Fedora 40 (Rawhide): Black screen after rebooting with Kernel 6.8 RC

I’m not sure if I can post my request here …

On the weekend, I tried Fedora 40 KDE Rawhide (Fedora-KDE-Live-x86_64-Rawhide-20240125.n.0.iso). Kernel 6.8.0-0.rc0.20240112git70d201a40823.5.fc40 was installed, and no newer kernel was offered.

Since kernel 6.7 there is a problem with AMD RX 7x00 XT graphics cards. This problem is still present in this kernel. When the computer is restarted, the monitor switches to standby mode after grub selection and does not wake up on the login screen. However, the OS is already loaded in the background, and you can try to log in blindly. You must shut down the computer completely so that the monitor does not switch back to standby mode when you start the computer again. The monitor will now work until the next system restart.

This issue exists since kernel 6.7. I had the same issue in Nobara 39 with kernel 6.7.0-200 installed. The developer was able to fix this issue by himself. With kernel 6.7.0-204 installed, the issue is fixed in Nobara 39. (See: Discord)

Maybe you already know about this issue? I just want to help to fix this issue before the official (beta-) release of Fedora 40. :wink:

1 Like

Definitely OK to ask about Fedora 40 Beta here.

Sounds like a good thing to file a Bugzilla report about it (if one doesn’t yet exist) and the Nobara fix could be useful.

Hopefully, it’ll get fixed upstream so all Linux distros get it, but filing a bugzilla report helps get the ball rolling if it hasn’t already started rolling.

1 Like

I’m not familiar with Bugzilla. I don’t even have an account there. I hope that someone is reading here and is able to help, maybe to create a Bugzilla report.

I know that the issue is fixed. But I don’t know how and what GE did to fix this.

Actually, I’m on Nobara 39 again. But I could install latest Rawhide ISO and check some things or create logs that I could provide.

Hopefully I’m not the only one having an AMD RX 7800 XT graphics card and want to use Fedora 40. :thinking:

Do we now have a filed bug report ?

I see the same thing with 20240112git70d201a40823.5.fc40.x86_64 and the previous 6.8.0-0.rc0.20240111gitde927f6c0b07.4.fc40

Don’t even know if it’s kernel related

UI simply doesn’t come up when starting gdm
sddm gives me a “Illegal instruction (core dumped)”


ARM64 Fedora Rawhide/f40 gives a blank screen display at the end of the booting process on Raspberry Pi-400 SBC.
x86_64 ,VMWare, Fedora Rawhide /F40 boots up cleanly on Kernel 6.8.0.rc0 .

I didn’t file one.

Yes. Yesterday I tried latest Rawhide with this kernel and the issue was still there.

I also tried switching kernel from Fedora to CashyOS 6.7.x in Rawhide and the issue still was there. Also, I installed latest openSUSE Tumbleweed with kernel 6.7.x and the issue was there too. So it seems that it isn’t an issue with Fedora kernel only.

Downgraded to kernel-core-6.7.0-0.rc8.20240104gitac865f00af29.64.fc40.x86_64 koji
as described here Downgrading to a previous kernel version and the issue persists
Ergo: most likely kernel not to blame

1 Like

As I wrote, the issue happens with kernel 6.7 and above. Only developer from Nobara fixed that issue in his kernel 6.7.0-204.

1 Like

ok – was a bit fast in reading (and skipping over) your comment

Now downgraded to 6.6.0-0.rc7.20231027git750b95887e56.58.fc40

Still no success

Getting the feeling that I sit on an unrelated bug

Some more details

  • display managers seem to have trouble
    – gdm gets stuck with a black VT
    – sddm crashes
  • lightdm however works and allows me a standfard GNOME session
  • good old rusty “startx” however pops me into a standard gnome session

my current suspect is wayland

THX for the help

All distributions I tested with kernel minor to 6.7.x, e.g. 6.6.x works. :thinking:

I’m not replacing distros I just downgrade the kernel
I’m sitting on fc40 for smt like 3 month now and it worked fine
The latest update however left me with a broken GUI
But in my case it doesn’t seem to be the kernel
Pure X11 also seems to work


I used Wayland only.

I would like to use Fedora 40.

The rawhide version is currently 40 and will remain so until 40 is branched in the near future. At that time rawhide will become 41 while the branched pre-release version will be 40.

I don’t suggest that you run either rawhide or the branched 40 until much closer to the expected release date of April unless you intentionally want to be using a pure developmental version and can live with any issues that pop up. Only testers should be running that version on a regular basis.


Since you are running 40 (rawhide) you should be reporting problems to the testing mailing list so the developers can become aware of the problems and hopefully fix them as part of the ongoing development cycle.

I have a VM running rawhide and just did an update after about 2 weeks with no updates. First boot gave me a solid black screen but a reboot worked normally with the login screen displayed and functional. The kernel is 6.8.0-0.rc0.20240112git70d201a40823.5.fc40.x86_64 and update was done just a few minutes ago.

Just a note to everyone!

The developers for rawhide probably do not monitor this forum.

If you are using rawhide it is a better choice to report problems on the tester mailing list so the problem is seem by the developers immediately.

1 Like

I’m on the very same kernel

Saying I have a black screen might be a bit misleading
I still have the normal text login and as u said u even get X11 running

FYI Bug report

1 Like

Thanks. I hope this is also my issue with the RX 7800 XT. I didn’t check any log files, because I don’t know how. Fingers crossed.

1 Like

You don’t need to go the whole way
Just start sddm from the console
If you are stuck on a black screen just do ALT F3
and you should get a console

1 Like

Just tried the latest Rawhide ISO (Fedora-KDE-Live-x86_64-Rawhide-20240203.n.0.iso). After installation issue appeared. The monitor went into sleep (Standby) when rebooting the system. But pressing ALT+F3 didn’t do anything. So, my issue isn’t your issue.

As I wrote, there seems to be an issue in connection to kernel 6.7.x (and above) and an AMD RX 7800 XT graphics card. Don’t know if it is the same with RX 7900 XT, but I think so. And it isn’t a specific Fedora issue.

After installing (an OS with) kernel 6.7.x or 6.8.x and rebooting, the monitor goes into sleep mode. There is no way to wake it up again by pressing keys. In the background, it seems that the OS is booting up. So it would be possible to log into the system without seeing anything. Pressing the power button shuts down the computer. Turning it on again and the boot screen is visible and also the login screen appears. Everything is working until the next reboot.

So, the only solution to prevent the monitor going to sleep is shutting down the computer when a reboot is needed.

Same issue for me now in Fedora 39 after installing kernel 6.7.3 … :frowning: