Codec (no longer) supported?

After the latest system update, I can no longer play .mkv files in VLC media player. I just get the following error:

Codec not supported:
VLC could not decode the format “hevc” (MPEG-H Part2/HEVC (H.265))

In the years I’ve used VLC, I’ve never seen this before. What’s odd is that the audio for mkv files does work, just no video, and the error message.
Other posts don’t have much of a solution and the only advice I get is to install libde265, but the instructions are usually for Ubuntu users.

VLC version:
3.0.20 Vetinari (Updated 15 Dec 2023)

System Software:
KDE Plasma Ver. 5.27.10
KDE Frameworks Ver. 5.111.0
Qt Ver. 5.15.11
Kernel Ver. 6.6.6-200.fc39.x86_64 (64-bit)
Graphics Platform: X11

libde265 is provided by rpmfusion from the rpmfusion-free repo, as is the x265-libs package.

https://rpmfusion.org/Configuration

Install both with sudo dnf install x265-libs libde265 after installing the repo files as shown in that link.

I’m getting that rpmfusion and the libde265 is already installed when I try this.

VLC has just been added to Fedora. Do you have libavcodec-freeworld (or ffmpeg-libs) installed from RPM Fusion?

If you do, it’s possible that there’s a problem with the new package. Please share rpm -qa | grep vlc

No, I’ve had it for nearly a year, now.
I’m not sure which one i have.

Here’s the info:

vlc-libs-3.0.20-4.fc39.x86_64
vlc-plugins-base-3.0.20-4.fc39.x86_64
vlc-plugin-lua-3.0.20-4.fc39.x86_64
vlc-cli-3.0.20-4.fc39.x86_64
vlc-plugins-video-out-3.0.20-4.fc39.x86_64
vlc-plugin-ffmpeg-3.0.20-4.fc39.x86_64
vlc-plugin-gnome-3.0.20-4.fc39.x86_64
vlc-plugin-kde-3.0.20-4.fc39.x86_64
vlc-plugin-notify-3.0.20-4.fc39.x86_64
vlc-plugin-pipewire-3-1.fc39.x86_64
vlc-plugin-visualization-3.0.20-4.fc39.x86_64
vlc-gui-qt-3.0.20-4.fc39.x86_64
vlc-gui-skins2-3.0.20-4.fc39.x86_64
vlc-3.0.20-4.fc39.x86_64
python3-vlc-3.0.20123-1.fc39.noarch

I should have been more clear; it was previously in RPM Fusion.

What about the codec packages I mentioned? I’m wondering if vlc-plugin-ffmpeg detects the available codecs at build time.

Edit: Testing here in a VM, libavcodec-freeworld makes h.265 playback work in VLC with the same packages installed (minus vlc-plugin-kde and python3-vlc).

same problem

I fixed it by reinstalling vlc, then autoremoving leftover packages sudo dnf autoremove and updating multimedia group sudo dnf group upgrade --with-optional Multimedia --allowerasing.
There was a conflict between ffmpeg and some more packages provided by rpm fusion and ffmpeg-free provided by fedora so had to remove the fedora ones.

1 Like

That did it. Thanks, everyone! :+1:

Worked like a charm! Thank you so much!

it is not working for me