Code42 Crashplan GUI crashes on Fedora 29

It looks like there was one question related to this on the old AskFedora site, but it never got answered. I’m trying to open the Code42 Crashplan GUI on a Fedora 29 installation and every time I try to launch it it crashes. The crash log is in /usr/local/crashplan/log, and the exact error is

/usr/local/crashplan/log/service.log.0:[05.02.19 15:08:48.545 INFO  main         .network.sabre.SabreNetworkLayer] SABRE:: Unable to load NettyTcNative library. Reason: java.lang.UnsatisfiedLinkError: unsupported JNI version 0x00010006 required by netty_tcnative

I checked and saw that I didn’t have netty-tcnative installed, but even after installing it I get the same error. It looks like it’s using its own packaged version of netty-tcnative, and it downloads its own jre-8u144-linux-x64 tarball during the installation process.

The same thing happens on a Fedora 30 live flash drive. Has anyone gotten this to work?


I think you should play with Java Version beginning with 1.6 , Maybe a compatibilty problem:

What java version do you have?

  • Oracle
  • Openjdk
rpm -qa java\*


java -version

I suggest to you, searching:

dnf search openjdk

Install jdk java 8 and java11 and switch between java’s with:

sudo alternatives --config java


These Flag’s mention about java version more reference here

#define JNI_VERSION_1_6 0x00010006


1 Like

Java packages installed:

$ rpm -qa java\*

Java version:

$ java -version
openjdk version "1.8.0_201"
OpenJDK Runtime Environment (build 1.8.0_201-b09)
OpenJDK 64-Bit Server VM (build 25.201-b09, mixed mode)

It’s strange that it would require such an old Java version, since it worked up until a few months ago. It definitely worked on Fedora 28; I don’t remember if it ever worked on 29 or not.

I just tried a couple of older versions my company has, and they work fine. I must have updated Crashplan at some point. The most recent version of Crashplan that I’m able to use is 6.5.0.