Cockpit Shows Warning for Disks in Btrfs RAID 1 Array

I’m unsure if this is a bug, or if I have failed to configure something properly, or if it isn’t really an issue at all.


  • My homelab file server has 5 disks. 1 150GB disk (sda) that I use for Fedora Server OS. 4 1TB drives that I have in a RAID 1 Btrfs array so that I have 2TB of available space that I had mounted as /home.
  • Recently, my OS disk failed, and I reinstalled Fedora Server 37 Beta (the USB was handy as I was doing testing on other systems, and I don’t believe this is a Beta issue) on the 150GB disk, but didn’t address the Btrfs array during the installation, so /home was not pointing to the 4 disks.
  • After Fedora Server 37 Beta finished installing, I manually removed /home and created a new /home.
  • I ran btrfs fi show which showed me the 4 1TB disks with just one UUID # which I copied.
  • I manually edited /etc/fstab to mount the UUID# I got from above, to mount to /home and then rebooted.
  • When the system came up I have /home resolving to my 4 1TB btrfs drives again. I even tested a backup script which rsyncs a backup from my Syncthing server to this file server, and it worked and saved the backup to the RAID 1 array. I checked after the backup script ran with btrfs fi show command and the size of the disks and total data on the RAID 1 array looks correct.
  • So I have what seems to be a working btrfs RAID 1 Array, but Cockpit sees issues a “warning” about 3 of the drives in the RAID 1 Array.

They have orange “!” next to them in the “Storage” tab and when you click on the drive and go to the “filesystem” tab it says:

Warning alert:Inconsistent filesystem mount
The filesystem is currently not mounted but will be mounted on the next boot.

Then there are two buttons which say:
“Do Not Mount Automatically On Boot” or “Mount Now”

  1. So, is this “expected behavior” and I can just leave it?
  2. This is “expected behavior” and I can just click on the button that says “Do No Mount Automatically on Boot” and it will remove this warning at the next boot.
  3. This is a bug in Cockpit and I should report it.
  4. I have failed to configure something because I manually edited the /etc/fstab and so Cockpit can’t see that this is a btrfs RAID 1 array.

I haven’t tried clicking on either of those buttons because I don’t want to mess up a working install of Fedora Server and a working RAID array since this is my backup file server.