Change keyboard layout in Fedora Server 40?

I’ve installed Fedora Server 40 on a virtual machine using the qcow2 image.
I’ve tried to change the keyboard layout from us to es using localectl instructions linked here:

The command succeeds, localectl output changes and /etc/vconsole.conf changes.
However the settings doesn’t actually change the active keyboard layout.
Changing it manually with loadkeys es works but settings are lost of course.
I’ve tried to rebuild the initramfs as I’ve read it could be necessary for settings to apply system wide but it didn’t make any difference.
Edit: I’ve installed the VM on Proxmox as ahost and I’m using noVNC method to access the local terminal.
What am I doing wrong?