Certain flatpaks not starting on one computer

I’m a happy Silverblue user on my laptop with few issues, and since I’ve been unhappy with my old messy HTPC setup, I wanted to try this tutorial for a Silverblue HTPC: https://fedoramagazine.org/convert-your-fedora-silverblue-to-htpc-with-kodi/ It’s an old Asus Haswell Chromebox which has been running like clockwork with a Ubuntu Minimal setup until now.

However, for some reason very few flatpaks actually properly work on the HTPC. (All work on my laptop with a similar setup, both running Wayland.) Running Kodi makes the Gnome top bar go away although Kodi doesn’t actually start, and trying to alt-tab or just do whatever just makes everything start flickering. Celluloid has similar issues. It’s not just video apps, Firefox flatpak doesn’t work either, regular socket or wayland override doesn’t matter. Bundled rpm Firefox works well, though. Running either of these through terminal doesn’t tell me much. It acts like it’s working, until the computer is basically non-responsive because no task switching or other seems to work. (I can however ssh in and systemctl reboot.) It’s not all flatpaks either, I just tried a random simple one (Dippi), and it works, alt-tab and everything, and I can quit it cleanly.

I’m finding this hard to debug, and Google has failed me so far (finding some flatpak issues with X11, but I’m on Wayland). Anyone with similar issues? I’ve tried both SB32 and a 33 reinstall, both Ext4 and btrfs. Same issues.