Can't update since fedora 35: missing mysql community GPG key

Hey, can’t update using gnome software because of error ‘could not do untrusted questions as no klass support’, dnf update doesn’t work. Can someone guide me to download the correct GPG-key please. These are the errors I get. Please help me.

$ sudo dnf update

MySQL 8.0 Community Server                                                                                                                    27 MB/s |  27 kB     00:00    
GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql (0x5072E1F5) is already installed
The GPG keys listed for the "MySQL 8.0 Community Server" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.. Failing package is: mysql80-community-release-fc35-1.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: GPG check FAILED

If i run:

$ grep 'gpgcheck=0' /etc/yum.repos.d/*

i get:


for different repositories


MySQL have updated their gpg key recently. My understanding is that by running:

sudo rpm --import

you should then be to proceed with: sudo dnf upgrade

Thanks Tom.

1 Like

I tried the two scripts you gave me but i am still getting incorrect gpg key. Any other thoughts? I am thinking it something to do with “Check that the correct key URLs are configured for this repository”
Thanks Tom,

Maybe you need to read this doc. Especially on part Selecting a Release Series.

Compare the result of your cat /etc/yum.repos.d/mysql-community.repo with the example presented on that doc page.

With your installed repo, most likely you will get:


And from doc page:

# Enable to use MySQL 8.0


Or maybe just disable your installed repo for mysql and install the newest repo from here.


Ah, @ankursinha post bellow have a good point.


Can you try installing the updated repo configuration rpm they give? You can download it here:

and then install it using dnf:

sudo dnf install <path to the downloaded rpm file>

(without the <> bits).

It includes the new key file, which dnf needs to find in the necessary location:

$ rpmls mysql80-community-release-fc35-2.noarch.rpm 
-rw-r--r--  /etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
-rw-r--r--  /etc/pki/rpm-gpg/RPM-GPG-KEY-mysql-2022
-rw-r--r--  /etc/yum.repos.d/mysql-community-source.repo
-rw-r--r--  /etc/yum.repos.d/mysql-community.repo

Modifying the repo file manually won’t work if the key file isn’t installed in the correct place, so best to just install the new repo rpm and that should fix all of this. Ideally, they should’ve handled this better and included the new repo rpm as an update using the older key before switching to the new key (to keep the chain of trust and allow automatic updating for users).

Edit: added explicit download and dnf based installation instructions


Hello Ankur,
I installed rpmdevltools and tried the command you posted, although I got the error
‘error: open of mysql80-community-release-fc35-2.noarch.rpm failed: No such file or directory’.

Then I proceeded to the link you shared and downloaded the version for fedora 35. The file opened gnome software “mysql80-community-release”. With a red garbage can button. I cannot uninstall the mysql80-community-release because of error “could not do untrusted question as no klass support”.

Hello Syaifur,

My repository looks like this after reverting it back to the original. Because i tried to manually change it.

$ cat mysql-community.repo
name=MySQL 5.7 Community Server 

name=MySQL 8.0 Community Server

name=MySQL Connectors Community

name=MySQL Tools Community

name=MySQL Tools Preview

Thank you,

Please be aware with the version mysql80-community-release-fc35-1.noarch.rpm and mysql80-community-release-fc35-2.noarch.rpm. Your repos is fc35-1 and what @ankursinha suggested to change to fc35-2 from link he shared.

1 Like

Hey everyone,

$ sudo dnf remove mysql80-community-release

i update my fedora!!! WOO HOO

$ sudo dnf update

538 updates later

Installed “mysql80-community-release” from gnome software using Ankur’s link.

Thank you so much for your time and efforts,


Hi, I’ve tried to sudo dnf update and I get the error of the title. I don’t know what to do. I hope for your help.


For which package/repo?

Thanks Tom.


It’ll be best if you can please copy the complete error and paste it here.

(Please see the introductory posts in the #start-here category if you’ve not had a chance yet—they explain how you can help others here help you)


As suggested by @ankursinha you need to give us the complete error. Simply copy that from the cli screen and paste into your post using the </> Preformatted text tags above so we can see the command and all the related text following.

Usually that GPG key error is because for some reason you do not have a valid key installed to verify the package to be updated or the package is being updated from a repo (3rd party) that does not have a key to provide for you.

1 Like

Hi, this is the command and the output.

$ sudo dnf update
Last metadata expiration check: 0:04:36 ago on Sat 22 Jan 2022 11:54:42 AM -05.
Dependencies resolved.
 Package                     Arch   Version             Repository         Size
 kernel                      x86_64 5.15.16-200.fc35    updates            15 k
 kernel-core                 x86_64 5.15.16-200.fc35    updates            35 M
 kernel-modules              x86_64 5.15.16-200.fc35    updates            33 M
 kernel-modules-extra        x86_64 5.15.16-200.fc35    updates           2.0 M
 abattis-cantarell-fonts     noarch 0.301-5.fc35        updates           364 k
 cryptsetup                  x86_64 2.4.3-1.fc35        updates           199 k
 cryptsetup-libs             x86_64 2.4.3-1.fc35        updates           430 k
 cups                        x86_64 1:2.3.3op2-12.fc35  updates           1.3 M
 cups-client                 x86_64 1:2.3.3op2-12.fc35  updates            71 k
 cups-filesystem             noarch 1:2.3.3op2-12.fc35  updates            14 k
 cups-filters                x86_64 1.28.11-1.fc35      updates           768 k
 cups-filters-libs           x86_64 1.28.11-1.fc35      updates           137 k
 cups-ipptool                x86_64 1:2.3.3op2-12.fc35  updates           3.9 M
 cups-libs                   x86_64 1:2.3.3op2-12.fc35  updates           266 k
 cxl-libs                    x86_64 72.1-1.fc35         updates            35 k
 daxctl-libs                 x86_64 72.1-1.fc35         updates            40 k
 dnsmasq                     x86_64 2.86-4.fc35         updates           333 k
 ethtool                     x86_64 2:5.16-1.fc35       updates           220 k
 evolution-data-server       x86_64 3.42.3-1.fc35       updates           2.2 M
                             noarch 3.42.3-1.fc35       updates           1.3 M
 expat                       x86_64 2.4.3-1.fc35        updates           111 k
 expat-devel                 x86_64 2.4.3-1.fc35        updates            53 k
 flatpak-libs                x86_64 1.12.3-1.fc35       updates           384 k
 gh                          x86_64 2.4.0-3.fc35        updates           6.5 M
 gnome-abrt                  x86_64 1.4.1-1.fc35        updates           141 k
 google-chrome-stable        x86_64 97.0.4692.99-1      google-chrome      86 M
 gstreamer1-plugins-bad-free x86_64 1.19.3-4.fc35       updates           2.8 M
                             x86_64 1.19.3-4.fc35       updates           438 k
                             x86_64 1.19.3-4.fc35       updates            20 k
                             x86_64 1.19.3-4.fc35       updates            18 k
                             x86_64 1.19.3-4.fc35       updates            16 k
 gupnp                       x86_64 1.4.3-1.fc35        updates           105 k
 gutenprint                  x86_64 5.3.4-6.fc35        updates           2.5 M
 gutenprint-cups             x86_64 5.3.4-6.fc35        updates           575 k
 gutenprint-libs             x86_64 5.3.4-6.fc35        updates           164 k
 harfbuzz                    x86_64 2.9.1-1.fc35        updates           679 k
 harfbuzz-icu                x86_64 2.9.1-1.fc35        updates            15 k
 hplip                       x86_64 3.21.12-1.fc35      updates            18 M
 hplip-common                x86_64 3.21.12-1.fc35      updates            73 k
 hplip-libs                  x86_64 3.21.12-1.fc35      updates           165 k
 ibus-m17n                   x86_64 1.4.9-1.fc35        updates            56 k
 ibus-typing-booster         noarch 2.15.15-1.fc35      updates           977 k
 initscripts                 x86_64 10.13-1.fc35        updates           217 k
 initscripts-service         noarch 10.13-1.fc35        updates            14 k
 libibverbs                  x86_64 38.1-2.fc35         updates           392 k
 libical                     x86_64 3.0.13-1.fc35       updates           289 k
 libical-glib                x86_64 3.0.13-1.fc35       updates           181 k
 libmetalink                 x86_64 0.1.3-24.fc35       updates            33 k
 libsane-hpaio               x86_64 3.21.12-1.fc35      updates            91 k
 libwacom                    x86_64 1.12.1-1.fc35       updates            46 k
 libwacom-data               noarch 1.12.1-1.fc35       updates           104 k
 libxcrypt                   x86_64 4.4.27-2.fc35       updates           118 k
 libxcrypt-compat            x86_64 4.4.27-2.fc35       updates            89 k
 libxcrypt-devel             x86_64 4.4.27-2.fc35       updates            29 k
 mesa-dri-drivers            x86_64 21.3.4-1.fc35       updates            26 M
 mesa-filesystem             x86_64 21.3.4-1.fc35       updates            18 k
 mesa-libEGL                 x86_64 21.3.4-1.fc35       updates           121 k
 mesa-libGL                  x86_64 21.3.4-1.fc35       updates           170 k
 mesa-libgbm                 x86_64 21.3.4-1.fc35       updates            44 k
 mesa-libglapi               x86_64 21.3.4-1.fc35       updates            53 k
 mesa-libxatracker           x86_64 21.3.4-1.fc35       updates           2.0 M
 mesa-vulkan-drivers         x86_64 21.3.4-1.fc35       updates           5.6 M
 mtools                      x86_64 4.0.37-1.fc35       updates           210 k
 mtr                         x86_64 2:0.95-1.fc35       updates            88 k
 mysql-community-client      x86_64 8.0.28-10.fc35      mysql80-community 3.9 M
                             x86_64 8.0.28-10.fc35      mysql80-community 1.3 M
 mysql-community-common      x86_64 8.0.28-10.fc35      mysql80-community 517 k
 mysql-community-devel       x86_64 8.0.28-10.fc35      mysql80-community 2.1 M
 mysql-community-libs        x86_64 8.0.28-10.fc35      mysql80-community 1.5 M
 mysql-community-server      x86_64 8.0.28-10.fc35      mysql80-community  18 M
 ndctl                       x86_64 72.1-1.fc35         updates           190 k
 ndctl-libs                  x86_64 72.1-1.fc35         updates            81 k
 nodejs                      x86_64 1:16.13.2-1.fc35    updates           200 k
 nodejs-docs                 noarch 1:16.13.2-1.fc35    updates           6.6 M
 nodejs-full-i18n            x86_64 1:16.13.2-1.fc35    updates           7.8 M
 nodejs-libs                 x86_64 1:16.13.2-1.fc35    updates            14 M
 npm                         x86_64 1:8.1.2-
                                                        updates           1.7 M
 pam                         x86_64 1.5.2-7.fc35        updates           547 k
 pcre2                       x86_64 10.39-1.fc35        updates           231 k
 pcre2-syntax                noarch 10.39-1.fc35        updates           144 k
 pcre2-utf16                 x86_64 10.39-1.fc35        updates           210 k
 pcre2-utf32                 x86_64 10.39-1.fc35        updates           200 k
 perl-Business-ISBN          noarch 3.007-1.fc35        updates            32 k
 pipewire                    x86_64 0.3.43-3.fc35       updates            38 k
 pipewire-alsa               x86_64 0.3.43-3.fc35       updates            62 k
 pipewire-gstreamer          x86_64 0.3.43-3.fc35       updates            57 k
                             x86_64 0.3.43-3.fc35       updates           134 k
 pipewire-libs               x86_64 0.3.43-3.fc35       updates           1.5 M
 pipewire-pulseaudio         x86_64 0.3.43-3.fc35       updates            27 k
 pipewire-utils              x86_64 0.3.43-3.fc35       updates           318 k
 python-unversioned-command  noarch 3.10.2-1.fc35       updates           9.5 k
 python3                     x86_64 3.10.2-1.fc35       updates            26 k
 python3-devel               x86_64 3.10.2-1.fc35       updates           207 k
 python3-libs                x86_64 3.10.2-1.fc35       updates           7.5 M
 python3-rpm                 x86_64 4.17.0-3.fc35       updates            91 k
 qgnomeplatform              x86_64 0.8.4-1.fc35        updates           175 k
 rpm                         x86_64 4.17.0-3.fc35       updates           537 k
 rpm-build-libs              x86_64 4.17.0-3.fc35       updates            93 k
 rpm-libs                    x86_64 4.17.0-3.fc35       updates           313 k
 rpm-plugin-selinux          x86_64 4.17.0-3.fc35       updates            20 k
 rpm-plugin-systemd-inhibit  x86_64 4.17.0-3.fc35       updates            20 k
 rpm-sign-libs               x86_64 4.17.0-3.fc35       updates            26 k
 rubberband                  x86_64 2.0.0-2.fc35        updates           261 k
 texlive-attachfile2         noarch 9:20210325-44.fc35  updates           448 k
 texlive-base                x86_64 9:20210325-44.fc35  updates           2.3 M
 texlive-bibtex              x86_64 9:20210325-44.fc35  updates           453 k
 texlive-dvipdfmx            x86_64 9:20210325-44.fc35  updates           3.0 M
 texlive-dvips               x86_64 9:20210325-44.fc35  updates           722 k
 texlive-glyphlist           noarch 9:20210325-44.fc35  updates            39 k
 texlive-gsftopk             x86_64 9:20210325-44.fc35  updates            36 k
 texlive-kpathsea            x86_64 9:20210325-44.fc35  updates           1.1 M
 texlive-latex               noarch 9:20210325-44.fc35  updates            22 M
 texlive-lib                 x86_64 9:20210325-44.fc35  updates           479 k
 texlive-luahbtex            x86_64 9:20210325-44.fc35  updates           1.9 M
 texlive-luaotfload          noarch 9:20210325-44.fc35  updates           1.2 M
 texlive-luatex              x86_64 9:20210325-44.fc35  updates           3.7 M
 texlive-lwarp               noarch 9:20210325-44.fc35  updates           3.2 M
 texlive-makeindex           x86_64 9:20210325-44.fc35  updates           431 k
 texlive-metafont            x86_64 9:20210325-44.fc35  updates           271 k
 texlive-mfware              x86_64 9:20210325-44.fc35  updates           107 k
 texlive-mptopdf             noarch 9:20210325-44.fc35  updates            53 k
 texlive-oberdiek            noarch 9:20210325-44.fc35  updates           8.6 M
 texlive-pdftex              x86_64 9:20210325-44.fc35  updates           2.0 M
 texlive-tex                 x86_64 9:20210325-44.fc35  updates           214 k
 texlive-texlive-en          noarch 9:20210325-44.fc35  updates           1.9 M
 texlive-texlive-scripts     noarch 9:20210325-44.fc35  updates           107 k
 texlive-texlive.infra       noarch 9:20210325-44.fc35  updates           283 k
 texlive-thumbpdf            noarch 9:20210325-44.fc35  updates            42 k
 texlive-xdvi                x86_64 9:20210325-44.fc35  updates           360 k
 texlive-xetex               x86_64 9:20210325-44.fc35  updates           1.3 M
 thermald                    x86_64 2.4.8-1.fc35        updates           235 k
 tigervnc-license            noarch 1.12.0-3.fc35       updates            16 k
 tigervnc-server-minimal     x86_64 1.12.0-3.fc35       updates           1.1 M
 virtualbox-guest-additions  x86_64 6.1.32-1.fc35       updates           1.4 M
 wireplumber                 x86_64 0.4.7-2.fc35        updates            70 k
 wireplumber-libs            x86_64 0.4.7-2.fc35        updates           308 k
Installing dependencies:
                             x86_64 8.0.28-10.fc35      mysql80-community 2.1 M
Installing weak dependencies:
 avahi-tools                 x86_64 0.8-14.fc35         fedora             39 k
 cups-filters-braille        x86_64 1.28.11-1.fc35      updates            38 k
 python3-tkinter             x86_64 3.10.2-1.fc35       updates           322 k
 kernel                      x86_64 5.15.12-200.fc35    @updates            0  
 kernel-core                 x86_64 5.15.12-200.fc35    @updates           76 M
 kernel-modules              x86_64 5.15.12-200.fc35    @updates           32 M
 kernel-modules-extra        x86_64 5.15.12-200.fc35    @updates          2.0 M

Transaction Summary
Install    8 Packages
Upgrade  132 Packages
Remove     4 Packages

Total size: 369 M
Is this ok [Y/n]: 
Downloading Packages:
[SKIPPED] avahi-tools-0.8-14.fc35.x86_64.rpm: Already downloaded               
[SKIPPED] cups-filters-braille-1.28.11-1.fc35.x86_64.rpm: Already downloaded   
[SKIPPED] kernel-5.15.16-200.fc35.x86_64.rpm: Already downloaded               
[SKIPPED] kernel-core-5.15.16-200.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] kernel-modules-5.15.16-200.fc35.x86_64.rpm: Already downloaded       
[SKIPPED] kernel-modules-extra-5.15.16-200.fc35.x86_64.rpm: Already downloaded 
[SKIPPED] python3-tkinter-3.10.2-1.fc35.x86_64.rpm: Already downloaded         
[SKIPPED] mysql-community-icu-data-files-8.0.28-10.fc35.x86_64.rpm: Already downloaded
[SKIPPED] abattis-cantarell-fonts-0.301-5.fc35.noarch.rpm: Already downloaded  
[SKIPPED] cryptsetup-2.4.3-1.fc35.x86_64.rpm: Already downloaded               
[SKIPPED] cryptsetup-libs-2.4.3-1.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] cups-2.3.3op2-12.fc35.x86_64.rpm: Already downloaded                 
[SKIPPED] cups-client-2.3.3op2-12.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] cups-filesystem-2.3.3op2-12.fc35.noarch.rpm: Already downloaded      
[SKIPPED] cups-filters-1.28.11-1.fc35.x86_64.rpm: Already downloaded           
[SKIPPED] cups-filters-libs-1.28.11-1.fc35.x86_64.rpm: Already downloaded      
[SKIPPED] cups-ipptool-2.3.3op2-12.fc35.x86_64.rpm: Already downloaded         
[SKIPPED] cups-libs-2.3.3op2-12.fc35.x86_64.rpm: Already downloaded            
[SKIPPED] cxl-libs-72.1-1.fc35.x86_64.rpm: Already downloaded                  
[SKIPPED] daxctl-libs-72.1-1.fc35.x86_64.rpm: Already downloaded               
[SKIPPED] dnsmasq-2.86-4.fc35.x86_64.rpm: Already downloaded                   
[SKIPPED] ethtool-5.16-1.fc35.x86_64.rpm: Already downloaded                   
[SKIPPED] evolution-data-server-3.42.3-1.fc35.x86_64.rpm: Already downloaded   
[SKIPPED] evolution-data-server-langpacks-3.42.3-1.fc35.noarch.rpm: Already downloaded
[SKIPPED] expat-2.4.3-1.fc35.x86_64.rpm: Already downloaded                    
[SKIPPED] expat-devel-2.4.3-1.fc35.x86_64.rpm: Already downloaded              
[SKIPPED] flatpak-libs-1.12.3-1.fc35.x86_64.rpm: Already downloaded            
[SKIPPED] gh-2.4.0-3.fc35.x86_64.rpm: Already downloaded                       
[SKIPPED] gnome-abrt-1.4.1-1.fc35.x86_64.rpm: Already downloaded               
[SKIPPED] gstreamer1-plugins-bad-free-1.19.3-4.fc35.x86_64.rpm: Already downloaded
[SKIPPED] gstreamer1-plugins-bad-free-extras-1.19.3-4.fc35.x86_64.rpm: Already downloaded
[SKIPPED] gstreamer1-plugins-bad-free-fluidsynth-1.19.3-4.fc35.x86_64.rpm: Already downloaded
[SKIPPED] gstreamer1-plugins-bad-free-wildmidi-1.19.3-4.fc35.x86_64.rpm: Already downloaded
[SKIPPED] gstreamer1-plugins-bad-free-zbar-1.19.3-4.fc35.x86_64.rpm: Already downloaded
[SKIPPED] gupnp-1.4.3-1.fc35.x86_64.rpm: Already downloaded                    
[SKIPPED] gutenprint-5.3.4-6.fc35.x86_64.rpm: Already downloaded               
[SKIPPED] gutenprint-cups-5.3.4-6.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] gutenprint-libs-5.3.4-6.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] harfbuzz-2.9.1-1.fc35.x86_64.rpm: Already downloaded                 
[SKIPPED] harfbuzz-icu-2.9.1-1.fc35.x86_64.rpm: Already downloaded             
[SKIPPED] hplip-3.21.12-1.fc35.x86_64.rpm: Already downloaded                  
[SKIPPED] hplip-common-3.21.12-1.fc35.x86_64.rpm: Already downloaded           
[SKIPPED] hplip-libs-3.21.12-1.fc35.x86_64.rpm: Already downloaded             
[SKIPPED] ibus-m17n-1.4.9-1.fc35.x86_64.rpm: Already downloaded                
[SKIPPED] ibus-typing-booster-2.15.15-1.fc35.noarch.rpm: Already downloaded    
[SKIPPED] initscripts-10.13-1.fc35.x86_64.rpm: Already downloaded              
[SKIPPED] initscripts-service-10.13-1.fc35.noarch.rpm: Already downloaded      
[SKIPPED] libibverbs-38.1-2.fc35.x86_64.rpm: Already downloaded                
[SKIPPED] libical-3.0.13-1.fc35.x86_64.rpm: Already downloaded                 
[SKIPPED] libical-glib-3.0.13-1.fc35.x86_64.rpm: Already downloaded            
[SKIPPED] libmetalink-0.1.3-24.fc35.x86_64.rpm: Already downloaded             
[SKIPPED] libsane-hpaio-3.21.12-1.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] libwacom-1.12.1-1.fc35.x86_64.rpm: Already downloaded                
[SKIPPED] libwacom-data-1.12.1-1.fc35.noarch.rpm: Already downloaded           
[SKIPPED] libxcrypt-4.4.27-2.fc35.x86_64.rpm: Already downloaded               
[SKIPPED] libxcrypt-compat-4.4.27-2.fc35.x86_64.rpm: Already downloaded        
[SKIPPED] libxcrypt-devel-4.4.27-2.fc35.x86_64.rpm: Already downloaded         
[SKIPPED] mesa-dri-drivers-21.3.4-1.fc35.x86_64.rpm: Already downloaded        
[SKIPPED] mesa-filesystem-21.3.4-1.fc35.x86_64.rpm: Already downloaded         
[SKIPPED] mesa-libEGL-21.3.4-1.fc35.x86_64.rpm: Already downloaded             
[SKIPPED] mesa-libGL-21.3.4-1.fc35.x86_64.rpm: Already downloaded              
[SKIPPED] mesa-libgbm-21.3.4-1.fc35.x86_64.rpm: Already downloaded             
[SKIPPED] mesa-libglapi-21.3.4-1.fc35.x86_64.rpm: Already downloaded           
[SKIPPED] mesa-libxatracker-21.3.4-1.fc35.x86_64.rpm: Already downloaded       
[SKIPPED] mesa-vulkan-drivers-21.3.4-1.fc35.x86_64.rpm: Already downloaded     
[SKIPPED] mtools-4.0.37-1.fc35.x86_64.rpm: Already downloaded                  
[SKIPPED] mtr-0.95-1.fc35.x86_64.rpm: Already downloaded                       
[SKIPPED] ndctl-72.1-1.fc35.x86_64.rpm: Already downloaded                     
[SKIPPED] ndctl-libs-72.1-1.fc35.x86_64.rpm: Already downloaded                
[SKIPPED] nodejs-16.13.2-1.fc35.x86_64.rpm: Already downloaded                 
[SKIPPED] nodejs-docs-16.13.2-1.fc35.noarch.rpm: Already downloaded            
[SKIPPED] nodejs-full-i18n-16.13.2-1.fc35.x86_64.rpm: Already downloaded       
[SKIPPED] nodejs-libs-16.13.2-1.fc35.x86_64.rpm: Already downloaded            
[SKIPPED] npm-8.1.2- Already downloaded            
[SKIPPED] pam-1.5.2-7.fc35.x86_64.rpm: Already downloaded                      
[SKIPPED] pcre2-10.39-1.fc35.x86_64.rpm: Already downloaded                    
[SKIPPED] pcre2-syntax-10.39-1.fc35.noarch.rpm: Already downloaded             
[SKIPPED] pcre2-utf16-10.39-1.fc35.x86_64.rpm: Already downloaded              
[SKIPPED] pcre2-utf32-10.39-1.fc35.x86_64.rpm: Already downloaded              
[SKIPPED] perl-Business-ISBN-3.007-1.fc35.noarch.rpm: Already downloaded       
[SKIPPED] pipewire-0.3.43-3.fc35.x86_64.rpm: Already downloaded                
[SKIPPED] pipewire-alsa-0.3.43-3.fc35.x86_64.rpm: Already downloaded           
[SKIPPED] pipewire-gstreamer-0.3.43-3.fc35.x86_64.rpm: Already downloaded      
[SKIPPED] pipewire-jack-audio-connection-kit-0.3.43-3.fc35.x86_64.rpm: Already downloaded
[SKIPPED] pipewire-libs-0.3.43-3.fc35.x86_64.rpm: Already downloaded           
[SKIPPED] pipewire-pulseaudio-0.3.43-3.fc35.x86_64.rpm: Already downloaded     
[SKIPPED] pipewire-utils-0.3.43-3.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] python-unversioned-command-3.10.2-1.fc35.noarch.rpm: Already downloaded
[SKIPPED] python3-3.10.2-1.fc35.x86_64.rpm: Already downloaded                 
[SKIPPED] python3-devel-3.10.2-1.fc35.x86_64.rpm: Already downloaded           
[SKIPPED] python3-libs-3.10.2-1.fc35.x86_64.rpm: Already downloaded            
[SKIPPED] python3-rpm-4.17.0-3.fc35.x86_64.rpm: Already downloaded             
[SKIPPED] qgnomeplatform-0.8.4-1.fc35.x86_64.rpm: Already downloaded           
[SKIPPED] rpm-4.17.0-3.fc35.x86_64.rpm: Already downloaded                     
[SKIPPED] rpm-build-libs-4.17.0-3.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] rpm-libs-4.17.0-3.fc35.x86_64.rpm: Already downloaded                
[SKIPPED] rpm-plugin-selinux-4.17.0-3.fc35.x86_64.rpm: Already downloaded      
[SKIPPED] rpm-plugin-systemd-inhibit-4.17.0-3.fc35.x86_64.rpm: Already downloaded
[SKIPPED] rpm-sign-libs-4.17.0-3.fc35.x86_64.rpm: Already downloaded           
[SKIPPED] rubberband-2.0.0-2.fc35.x86_64.rpm: Already downloaded               
[SKIPPED] texlive-attachfile2-20210325-44.fc35.noarch.rpm: Already downloaded  
[SKIPPED] texlive-base-20210325-44.fc35.x86_64.rpm: Already downloaded         
[SKIPPED] texlive-bibtex-20210325-44.fc35.x86_64.rpm: Already downloaded       
[SKIPPED] texlive-dvipdfmx-20210325-44.fc35.x86_64.rpm: Already downloaded     
[SKIPPED] texlive-dvips-20210325-44.fc35.x86_64.rpm: Already downloaded        
[SKIPPED] texlive-glyphlist-20210325-44.fc35.noarch.rpm: Already downloaded    
[SKIPPED] texlive-gsftopk-20210325-44.fc35.x86_64.rpm: Already downloaded      
[SKIPPED] texlive-kpathsea-20210325-44.fc35.x86_64.rpm: Already downloaded     
[SKIPPED] texlive-latex-20210325-44.fc35.noarch.rpm: Already downloaded        
[SKIPPED] texlive-lib-20210325-44.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] texlive-luahbtex-20210325-44.fc35.x86_64.rpm: Already downloaded     
[SKIPPED] texlive-luaotfload-20210325-44.fc35.noarch.rpm: Already downloaded   
[SKIPPED] texlive-luatex-20210325-44.fc35.x86_64.rpm: Already downloaded       
[SKIPPED] texlive-lwarp-20210325-44.fc35.noarch.rpm: Already downloaded        
[SKIPPED] texlive-makeindex-20210325-44.fc35.x86_64.rpm: Already downloaded    
[SKIPPED] texlive-metafont-20210325-44.fc35.x86_64.rpm: Already downloaded     
[SKIPPED] texlive-mfware-20210325-44.fc35.x86_64.rpm: Already downloaded       
[SKIPPED] texlive-mptopdf-20210325-44.fc35.noarch.rpm: Already downloaded      
[SKIPPED] texlive-oberdiek-20210325-44.fc35.noarch.rpm: Already downloaded     
[SKIPPED] texlive-pdftex-20210325-44.fc35.x86_64.rpm: Already downloaded       
[SKIPPED] texlive-tex-20210325-44.fc35.x86_64.rpm: Already downloaded          
[SKIPPED] texlive-texlive-en-20210325-44.fc35.noarch.rpm: Already downloaded   
[SKIPPED] texlive-texlive-scripts-20210325-44.fc35.noarch.rpm: Already downloaded
[SKIPPED] texlive-texlive.infra-20210325-44.fc35.noarch.rpm: Already downloaded
[SKIPPED] texlive-thumbpdf-20210325-44.fc35.noarch.rpm: Already downloaded     
[SKIPPED] texlive-xdvi-20210325-44.fc35.x86_64.rpm: Already downloaded         
[SKIPPED] texlive-xetex-20210325-44.fc35.x86_64.rpm: Already downloaded        
[SKIPPED] thermald-2.4.8-1.fc35.x86_64.rpm: Already downloaded                 
[SKIPPED] tigervnc-license-1.12.0-3.fc35.noarch.rpm: Already downloaded        
[SKIPPED] tigervnc-server-minimal-1.12.0-3.fc35.x86_64.rpm: Already downloaded 
[SKIPPED] virtualbox-guest-additions-6.1.32-1.fc35.x86_64.rpm: Already downloaded
[SKIPPED] wireplumber-0.4.7-2.fc35.x86_64.rpm: Already downloaded              
[SKIPPED] wireplumber-libs-0.4.7-2.fc35.x86_64.rpm: Already downloaded         
[SKIPPED] google-chrome-stable-97.0.4692.99-1.x86_64.rpm: Already downloaded   
[SKIPPED] mysql-community-client-8.0.28-10.fc35.x86_64.rpm: Already downloaded 
[SKIPPED] mysql-community-client-plugins-8.0.28-10.fc35.x86_64.rpm: Already downloaded
[SKIPPED] mysql-community-common-8.0.28-10.fc35.x86_64.rpm: Already downloaded 
[SKIPPED] mysql-community-devel-8.0.28-10.fc35.x86_64.rpm: Already downloaded  
[SKIPPED] mysql-community-libs-8.0.28-10.fc35.x86_64.rpm: Already downloaded   
[SKIPPED] mysql-community-server-8.0.28-10.fc35.x86_64.rpm: Already downloaded 
MySQL 8.0 Community Server                      1.9 MB/s | 1.9 kB     00:00    
GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql (0x5072E1F5) is already installed
The GPG keys listed for the "MySQL 8.0 Community Server" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.. Failing package is: mysql-community-icu-data-files-8.0.28-10.fc35.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
Public key for mysql-community-client-8.0.28-10.fc35.x86_64.rpm is not installed. Failing package is: mysql-community-client-8.0.28-10.fc35.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
Public key for mysql-community-client-plugins-8.0.28-10.fc35.x86_64.rpm is not installed. Failing package is: mysql-community-client-plugins-8.0.28-10.fc35.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
Public key for mysql-community-common-8.0.28-10.fc35.x86_64.rpm is not installed. Failing package is: mysql-community-common-8.0.28-10.fc35.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
Public key for mysql-community-devel-8.0.28-10.fc35.x86_64.rpm is not installed. Failing package is: mysql-community-devel-8.0.28-10.fc35.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
Public key for mysql-community-libs-8.0.28-10.fc35.x86_64.rpm is not installed. Failing package is: mysql-community-libs-8.0.28-10.fc35.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
Public key for mysql-community-server-8.0.28-10.fc35.x86_64.rpm is not installed. Failing package is: mysql-community-server-8.0.28-10.fc35.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: GPG check FAILED

Please take a look here



getting the same with RPM-GPG-KEY-mysql-2023 gpg key …