Can't install software with gnome software

hello everybody

i’m facing this problem i can’t install things as gnome software says i don’t have the permission to do that
i tried deleting the login key on seahorse but on restart it didn’t ask me to create a new one, so i suspect this may be related

of course dnf is working as usual

any hints?for the record im in workstation 34

just in case, this is what journalctl says about removing a software

ago 23 15:04:07 fedora PackageKit[1448]: uid 1000 is trying to obtain org.freedesktop.packagekit.package-remove auth (only_trusted:0)
ago 23 15:04:07 fedora PackageKit[1448]: uid 1000 failed to obtain auth

Out of curiosity, what are the polkit rules you have in place?
sudo find /etc/polkit-1/ -type f



Here it is

Do you have this file /usr/share/polkit-1/actions/org.freedesktop.packagekit.policy
And this one? /usr/share/polkit-1/rules.d/org.freedesktop.packagekit.rules
Is PackageKit installed?

1 Like

yes to all 3 questions

and rules file says i’m in the wheel group with everything set to true…

And out of curiosity, a command like systemctl reset-failed (without sudo) does it trigger the window asking for the password?


Also check this:

systemctl --failed
rpm -q -a gnome-software\* PackageKit\* polkit\* | sort
sudo rpm -V -a gnome-software\* PackageKit\* polkit\*

And perform that:

1 Like

But my goal was to issue a command that normally would pop up a window asking for the password. This in order to understand if the problem is limited to gnome-software or if it is extended to the whole polkit (or whatever).

In addition to the two log messages you posted, are there other ones (related to polkit) before these?
What happens (just for testing purposes) if you create a new user and you try with it?


ok so

does it trigger the prompt for the password

the result for this is


the result for this

it’s just nothing, meaning that when i enter the password i just get another terminal line to input a new command

i’ll try the new user in the meantime

anyway there’s clearly more cause my browser is not able to save passwords anymore…


Which browser?

using vivaldi here…i’ll try with eolie or epiphany but i’m guessing i will have the same result…

Doesn’t Vivaldi use a built in system to store passwords?

don’t really know, but i’m guessing it’s using the usual gnome keyring

anyway the new user has the same issue…

tried also with eolie and epiphany and they are not able to save my passwords so must be something system wide, or anyway connected to the keyring…

tried, that was not the solution…

1 Like

Some more log?
journalctl -b | fpaste
(Even if it could be a lot of stuff, due to -b print all the logs since the last boot)

1 Like

Log close to when the action occurred?

Hi Luca,
Just curious: if you go to Settings (cog right corner) → Users → [username who wants to install software with gnome software], is that user administrator? If not, make it; if so, try ‘on-off’-action.

Maybe you just should remove ~/.local/share/keyrings/login.keyring (or better: make backup of it) and logout and login again. This should generate a new key, see

1 Like

done and rebooted, seems that it has not created a new one…

weirdly enough, in this log the thing started working again, i absolutely don’t know why

but then i rebooted and everything is not working again

here’s the non working state log