Can't connect to wifi after update (bcm4360 with broadcom-wl driver)

I just updated to Fedora 30 on my Macbook Air and can no longer connect to wifi using the broadcom-wl driver from RPMFusion. WiFi networks are displayed and I can click in NetworkManager to connect, but it ultimately just returns the error “Activation of network connection failed”.

Here’s what I get when running lspci -k :

03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)
`Subsystem: Apple Inc. Device 0117`
`Kernel driver in use: wl`
`Kernel modules: bcma, wl`

Here’s what I get when I run iwconfig :

wlp3s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=200 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

And rfkill says everything is unblocked:

0 wlan phy0 unblocked unblocked

Any ideas?


Maybe you need remove & reinstall the driver (akmod…), remember the current kernel is updated.

I already reinstalled broadcom-wl and associated packages (akmods) using DNF. Akmods should be automatically changing the kernel, plus I was running this kernel on F29 with no problems.

Same problem here after upgrading to fedora 30, my broadcom wifi stopped working.
I have reinstalled the broadcom driver from rpm fusion and akmod, still it is not working.

1 Like

Then, for some strange reason the modules isn’t built; I personally use the dkms driver from UnitedRPMs; and works great, 0 problems… If you are tired, maybe works for you…

  1. Enable repository

  2. Install the driver

dnf remove broadcom-wl kmod-wl

dnf install broadcom-wl-dkms

1 Like

I just tried that and it doesn’t work either… Still “connecting…”, then “activation failed”, then trying to connect again.
Interestingly, with broadcom-wl I actually noticed that (once) after trying to connect for like an hour it eventually worked (temporarily - attempting to change networks or reconnecting reset the whole cycle)


I told you hahaha :smile:

Any other ideas? It seems connecting eventually works but takes an hour or two each time…

Unfortunately, I think this seems to indicate a driver issue. We’ll have to look into a bit. Maybe worth investing in a cheap wifi dongle thing in the meantime. You get cheap ones for a fiver on amazon etc.

Before I got my new system (a Thinkpad), I had the broadcom wifi too, and even though support has improved considerably, it’s still buggy at times :slightly_frowning_face:

After upgrading to F30 I have the same problem with a BCM4352, Wifi@F29 worked without problems. Wifi is available only after some manual connects.

03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4352 802.11ac Wireless Network Adapter (rev 03)
	Subsystem: AzureWave Device 2123
	Kernel driver in use: wl
	Kernel modules: bcma, wl

This bug has already been described.

For an interim solution, you could either use the test build from koji at or wait for the official update.



I have the same problem, and after install de wpa_suppliment 2.8 Works.

Removing the wl module & instaling the build from koji (& then rebooting) worked for me as well!


Same problem. RPMFusion driver won’t work. Haven’t tried others. Wish this could be as easy as in ubuntu.

Easy to fix with the suggested test build from koji. No problem anymore.


Was just looking into installing fedora 30 on my laptop when I came across this issue.

Has anyone tried using the 2.8 branch of wpa_supplicant from rawhide?

I used and work on my Mac same broadcom wifi card

1 Like

Downgrading specifically to wpa_supplicant-2.6-17.fc29.x86_64.rpm and then excluding wpa_supplicant in dnf.conf has been the only solution that worked for me so far. I’m using a MacBook Pro 7,1 and with this method I still have a few issues with WiFi but it’s very sparse.


The updated “wpa_supplicant” solves the issue (isn’t problem with the driver), if you don’t want wait the update you can download HERE :wink:


It would be nice to know when this updated package will be in the fedora30 repos. :slight_smile: