Can't connect to EC2 instance on Fedora 32

Hey guys,

I’m trying to connect in one of my EC2 instances, but I get the below error:

Permission denied (publickey,gssapi-keyex,gssapi-with-mic)

It seems that the problem is OpenSSH, but I couldn’t find any solution.

Open SSH version: OpenSSH_8.3p1.
Has anyone else faced this problem? Also I tried this solution but it didn’t work.

This question is probably better for Ask Fedora. That said, my first guess is the crypto policy update in Fedora 33. See Fedora 33 Release Notes: Security : Strong Crypto Settings for details.

Thanks @mattdm! I’ll ask there.
Unfortunately adding PubkeyAcceptedKeyTypes didn’t work.

Reference: