Cannot update Silverblue using 'rpm-ostree update'

I receive an error message stating:

syscore cleanup: pruning system repository: Deleting object 'long string of numbers and letters.file unlinkat (more long string of letters.file): No such file or directory.

How do I resolve this?

System never updates, just falls back to prompt.

Please help if you can.

Thank you,


Something similar happened to me a few times before. I can’t claim I know what’s happening here, but I suspect the file system. A file gets corrupted maybe or partially deleted, I don’t know, but it sits in some limbo state of existing and not existing at the same time. Other commands spit out similar errors if you try to use them on the file.

What fixed it for me (the most recent time this happened) was booting to a live USB session and checking the btrfs filesystem with # btrfs check --repair a couple of times. Then booting back to silverblue and running # ostree fsck --delete. The update went through after that.

A big warning here though. These commands are quite risky. Attempt running them only if:

  • You didn’t find a better solution.
  • You have everything you care about backed up.
  • You have time to reinstall the OS if necessary.


Thanks for the response. I did a rpm-ostree cleanup --rollback, and it started to upgrade without the error message. Once I restarted, I noticed the update did not stick. I tried that a few times with the same result. Now I get to another error message:

system core: pruning that ends with ‘read-only file system’ message.

You got it, aitvaras,

I loaded a live Fedora Workstation and unlocked the LUKS partition without mounting the device at /dev/mapper/UUID and check and repaired. Found many errors. Booted back into main OS and updated, and it worked. Thank you so much. Did not want to reinstall.