Cannot force WiFi bitrate

I am using a buitl-in atheros Wireless chip on my laptop, bu tthe connection is always at 1 Mbit/s. It does not matter whether I am close to the router or far.

According tho the specification this chip supports modern connection methods, and the router connects to other device just fine from 54Mbits/s and higher:

“The QCA9377 is a single-die wireless local area network (WLAN) and Bluetooth combination solution to support 1 × 1 802.11a/b/g/n/ac WLAN standards and Bluetooth 5.0 + HS, designed to deliver superior integration of WLAN/Bluetooth and low-energy technology.”

The driver being used is: ath10k_pci on Fedora.

I have tried to force the rate, run on different channels and tried using iwconfig and modprobe tricks, but whenever I look a the connection or restarting and retrying, the connections remains to be 1Mbits/s

01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

wlp1s0 IEEE 802.11 ESSID:“RT1 @LifeHealth
Mode:Managed Frequency:2.442 GHz Access Point: 60:14:66:58:8E:6D
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=51/70 Signal level=-59 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:4 Missed beacon:0

My question, what can I do so my wifi adapter/connection can connect at 5.5Mbits/s or even 11Mbits/s

Hello, I also have the same impression as you, it is not today that I have problems like this, I was a user of Manjaro and sometimes the wireless internet falls out of nowhere. I have the impression that the wireless connection does not deliver everything it can in linux distros in general (I know it is not the fault of the distros but the company responsible for these drivers there), could someone help us?