Cannot click on GNOME menu/statusbar items when sth. is in fullscreen in Fedora 36


  1. Open anything in fullscreen mode. E.g. you can press F11 here and your browser [tested with rpm-ostreed Firefox] should switch to fullscren, watch a fullscreen video on any popular website, use a special website or even watch a video with GNOME Videos in fullscreen.
    The only other requirement is that this fullscreen window has to be in focus.
  2. Now press the Super key or somehow else navigate to GNOMEs overview screen, so you see the Activities overview.
  3. Now try to click on the top right (clock, shutdown menu etc.) or e.g. on the current date (calendar etc.) or, if installed, GNOME extensions that have something (a panel) there like OpenWeather.
    • I do have a touch screen here, and the issue is weirdly not reproducible when you touch!
      Edit: Oh it actually is, it worked just now, but trying it again it also fails. I need to click two or more times to open it actually, I’d say it’s lottery-like, it works in 30% of the cases.
    • Note: The issue is also not reproducible when you click on “Activities” to just close the Activities screen, that works.

What happens

Well nothing.

  • The hover animation (background highlight) works.
  • The click animation never appears (the background is a little bit darker)
  • Worse of course, the menu never opens.

What should happen

  • menu should always be possible to open
  • also touch should behave the same as a click…


  • switch the active window
  • switch to another workspace (it seems IMHO properly to be separately per workspace)
  • close the fullscreen mode

If I had to guess…

…somehow wrongly implemented this as a feature and did not thought of the fact that you can use a keyboard to open the activities overview.
IMHO/I actually see no reason to disable that menu there at all.

Use cases

There are plenty ones, but e.g. when watching a video I may want to quickly have a look into my calendar to find out what whether I have time or whatever… or look at the weather etc.
This is not possible without stopping the fullscreen mode or so (see above)…


GNOME 42.1, Wayland
Version: 36.20220512.1 (2022-05-12T20:00:12Z)


I just tested this out, and it works for me here on X. So it could be a wayland specific issue. A few things to test to confirm the issue:

  • can you create a new user and see if the issue persists there
  • can you test with both X and wayland to see if there’s a difference?

If this is a bug, it will need to be reported—this is only the support forum, not the bug tracker so devs don’t keep an eye for issues here.

Yes same problem here, I can’t access top menu bar when I played vlc in full screen then press super button. VLC must be exit from full screen so I can access top menu bar. I use wayland in Ghome 42 in Fedora 36.

Okay, as it has been confirmed, I created a bug report now:


Upstream says this is fixed in 42.1 (not yet in Fedora).

1 Like