Cannot boot into gui and instead emergency mode, Generating "run/initramfs/rdsosreport.txt"

Been using fedora on my Lenovo laptop for a few months, iam not that experienced with Linux and I have little knowledge about the terminal and commands, I didn’t update my laptop that much and right now I cant access it and idk what to do, there are a few posts similar like this but none helped with this issue, I think it’s related to btrfs filesystem something like that

Is the laptop configured with dual boot, or only Fedora? Is the drive encrypted?
Was there anything abnormal

about the last time you shutdown Fedora?

Linux will run fsck at boot time if the last shutdown was abnormal (laptop crashed or ran out of battery) or after a certain time has passed without running fsck. Btrfs doesn’t need fsck after an abnormal shutdown. It look like the root partition can’t be mounted.

If you have a Live Installer USB key, you can boot that and use Gnome Disks to check the laptop’s internal drive. You should see the drive and partitions. Check the S.M.A.R.T drive health. Then try mounting the root directory (a large partition with brtfs format).

Sorting out linux problems often requires using the command-line, and getting help from online forums is much more efficient when you can use a terminal and provide text (bracketed with </> for terminal output). There are many good online tutorials. Linux Command has been around for a long time so has been thoroughly fact checked. There are even more bad, incorrect, and misleading tutorials being generated by cutting and pasting other people content or using AI’s. There also many local linux groups that meet regularly and have allocated time to troubleshoot linux problems if you show up with your laptop.

Hey, thanks for reaching and helping me out.

The laptop has dual boot enabled, fedora and windows and both dont work, it wasnt encrypted and there wasnt anything abnormal other than the cpu clockspeeds for a few seconds after boot but the nvme drive had no issues

It was an abnormal shutdown, before that happened i didn’t use the laptop that much so i wasn’t updating it regularly, after i just booted it on after a few minutes the usb ports didnt work and so were the inbuilt keyboar and mouse, so i force shutdown it using the power button and booting it up to find it like that, my guess is the laptop froze for some reason and it auto updated and when that happened it didnt finish updating and i force shutdown it.

Yeah the booting up it says “sysroot.mount cannot be mounted” i dont know what couldve caused this issue, i use fedora also on another older laptop for like a year now and i didnt encounter something like that.

I tried to boot from a live usb with fedora but i couldnt detect the nvme drive, i tried a different distro but it didnt also detect the drive so i wasnt able to run SMART tests on it

The nmve drive is in good condtion and i ran some testes from the UEFI on boot and it there were no errors so the problem is not related to hardware but i couldnt also detect it from a live usb so i dont know what do at this point

Strange that you can get UEFI but neither OS. This indicates a UEFI or drive problem. There is not much you can do if the drive isn’t recognized by the installers. Did you use Lenovo’s Bootable USB with UEFI Diagnostics? There may be a bootable drive test from the drive’s manufacturer.

Lenovo BIOS, UEFI solutions may help.