Cannot boot into Fedora 34; mount: /sysroot: unknown filesystem type

Hi everyone,
The other day i accidentally deleted /bin, so i panicked and made a /bin folder, copied everything from /usr/bin into it.
This sort of worked but stuff like steam wouldn’t start up properly, if at all.
Then after reading online and on Wikipedia, i found out that nowadays /bin is a symlink to /usr/bin for most distros, including Fedora.
On the Fedora IRC, i was also told that i should symlink /sbin to /usr/sbin. Not sure if this did anything, but /sbin was empty anyway.

TL:DR; see following journalctl log, as stated in the title, the startup fsck also fails with exit code 8.
journalctl log

1 Like

On my system /bin is symlink to /usr/sbin and /sbin is a symlink to /usr/sbin.

I think this was done because in times past different distros used one or the other path and software was written with the paths hard-coded. Thus by having a symlink it makes things more standardized for access.

Assuming you actually created a real directory and copied everything from /usr/sbin over, I think if you simply delete /bin and its content, then recreate the symlink it should all be fine. Fedora installs all the binaries into /usr/sbin and /usr/bin so the only purpose of the symlink is to handle programs that look for binaries in /bin or /sbin and avoid having multiple copies of the same things.

You see similar with /lib and /usr/lib as well as /lib64 and /usr/lib64.

The links can be seen by doing “ls -l /”.

# ls -l /
total 69
lrwxrwxrwx.   1 root root     7 Jan 26  2021 bin -> usr/bin
drwxr-xr-x.   8 root root  4096 Sep  6 02:18 boot
drwxr-xr-x.  26 root root  4700 Sep  7 20:22 dev
drwxr-xr-x. 226 root root 12288 Sep  8 11:20 etc
drwxr-xr-x.   5 root root  4096 Jan 26  2021 home
lrwxrwxrwx.   1 root root     7 Jan 26  2021 lib -> usr/lib
lrwxrwxrwx.   1 root root     9 Jan 26  2021 lib64 -> usr/lib64
drwx------.   2 root root 16384 Apr 22  2020 lost+found
drwxr-xr-x.   2 root root  4096 Jan 26  2021 media
drwxr-xr-x.   2 root root  4096 Aug  6 11:51 mnt
drwxr-xr-x.   6 root root  4096 Aug 29 20:38 opt
dr-xr-xr-x. 453 root root     0 Sep  2 11:36 proc
drwxr-xr-x.   2 root root  4096 Mar 15 21:29 products
dr-xr-x---.  16 root root  4096 Sep  8 08:42 root
drwxr-xr-x.  68 root root  1740 Sep  7 13:08 run
lrwxrwxrwx.   1 root root     8 Jan 26  2021 sbin -> usr/sbin
drwxr-xr-x.   2 root root  4096 Aug  6 11:51 srv
dr-xr-xr-x.  13 root root     0 Sep  2 11:36 sys
drwxrwxrwt.  28 root root  1160 Sep  8 12:19 tmp
drwxr-xr-x.  16 root root  4096 Aug  6 11:51 usr
drwxr-xr-x.  22 root root  4096 Aug  6 12:53 var

On my system /bin is symlink to /usr/sbin and /sbin is a symlink to /usr/sbin

I just tried live booting and changing /bin ---> /usr/sbin and nothing changed. If anything the live Fedora iso i was using, had bin pointing at /usr/bin.
I still can’t boot into my system, thanks for the info though.

With the fsck error in that log I would suggest booting to live usb and then running fsck on all the partitions on sda (1 thru 5) to make sure everything is good and to repair errors.

A quick search for “what is fsck error 8” gives me many (500,000) links for the meaning and fix, notably this one.

You should recognize that any fsck error should be investigated and fixed to prevent further corruption. Fsck normally does not report an error unless file system corruption is present.

Alright, so i tried live-booting once again, moved bin ---> /usr/bin, tried fsck’ing it, and it says that the filesystem is clean, so i forced it and there was nothing out of the ordinary, no bad superblocks.
So i thought: “the last journalctl lines complain about the peripherals, and before i failed to boot i did a kernel update, so maybe it’s a kernel issue? would make sense since i’m using kernel-lqx (fedora port of the liquorix kernel)”
So i booted another, older kernel, and now it started… almost fine, until it would get stuck on filtering iptables by arp/ip[something]/[etc/something else is not supported use X instead (i didn't write it out, so i'm going by memory).
Tried opening another tty but somehow i couldn’t log in at all, it would loop back to the login screen after a few seconds.

I also tried chrooting, removing kernel-lqx, installing the default kernel. But then i didn’t know how to update/tell GRUB which kernel to boot. (update-grub/grub2 failed with some error i can’t remember, which i fixed, only for it to give another one.)

At this point i’m starting to ask if it’s even worth it, maybe i should install OpenSUSE; not because Fedora is a bad distro, but because i wanted to kill two birds with one stone, by also trying it out.

EDIT: not to be rude or anything, but this is the second time i’ve asked for help about this
(first on the IRC and then here) and i’ve waited days without access to my computer; so i guess i’m going to install OpenSUSE instead i guess…