Error booting: Generating "/run/initramfs/rdsosreport.txt"

I upgraded from F29 to F30. On rebooting, all I see is a black screen with Generating “/run/initramfs/rdsosreport.txt”

What do I do? I tried all four grub options with the same result. I saw no obvious errors while upgrading.

Edit1: After some time, it dropped into a terminal and I ran $(cat /run/initramfs/rdsosreport.txt) and one thing that stands out is:

systemctl: Failed to switch root: Specified switch root path '/sysroot' does not seem to be an OS tree. os-release file is missing.

Edit2: It seems my main filesystem is mounted read-only under /sysroot. Running $(ls -l /sysroot/etc/os-release) shows it’s a symlink to “…/usr/lib/os-release”. Running $(ls -l /sysroot/usr/lib/os-release) shows it’s a symlink to “./os.release.d/os-release-fedora”. Running $(ls -l /sysroot/usr/os.release.d) shows it does not exist.

Edit3: I’m able to mount the main filesystem as read-write with $(mount -o remount,rw /sysroot). Now I just need to figure out how to correct the os-release file.

Edit4: I was able to boot successfully with:

rm /sysroot/etc/os-release
cp /usr/lib/os-release /sysroot/etc/os-release

Then I found some conflicts in dnf and ran $(dnf install --allowerasing fedora-release-workstation-30-3) which removed fedora-release-matecompiz-30-3 and I don’t know why that was installed. Then I ran:

sudo rm /etc/os-release
sudo ln -s /usr/lib/os-release /etc/os-release
sudo reboot

Well, it seems like you’ve fixed it, but for the future note that common issues like this are listed on the wiki, usually with workarounds, i.e., this issue you’ve faced with conflicting fedora-release packages.


@kevg: Thank you for your helpful post and detailed description; it helped me a lot. Is it possible for you to post your solution as an answer to your own question and mark it as the “accepted solution”? The currently accepted solution is not constructive.