Can’t click/interact with windows/open apps in Fedora 37

Hi everyone

So for some weird reason when I start up an application it lets me move the window and interact with the application (just like expected), but after a few seconds it won’t let me move nor interact with the window?

I can still interact with the shell (the OS), but it won’t let me click inside or move windows of apps I opened. I can however change the window focus. The keyboard still works (I can interact with the apps etc) and I can open a new terminal window and switch to a VT.

I tried disabling Gnome Extensions without any succes. I also tried logging into an Xorg session instead of a Wayland session and everything behaved normal (I can click and move windows as expected)

Currently I am running Fedora 37 (Workstation Edition) with Wayland on the 5.19.16-301.fc37.x86_64 kernel and I use Mutter as WM (the default)

The weird thing is I don’t know what triggered this behaviour because everything was working as expected and then it suddenly didn’t. I only tried installing Wine, but after removing Wine the issue still remains.