Can’t boot with newer kernel (inteldrmfb problem)

I haven’t been able to boot a newer kernel since 5.6.13. Boot just freezes and when running boot in a not quiet mode I can see that it stops on **switching to inteldrmfb from EFI VGA ** everytime

I always use the GUI updates and very seldom install any new programs. I can’t think this problem is related to anything I have done. It just didn’t work after a system update. I have tried almost all later updates but I always have to use 5.6.13 to be able to boot.

So what could be wrong and how do I fix it? If anyone could help me I would be thankful

No one? Guess it is driver related for the graphics card but how do I get the new drivers installed?

I had the same error, and what worked for me was enabling IOMMU support through a boot flag in GRUB. Type in the command: sudo grubby --args="intel_iommu=on" --update-kernel /boot/vmlinuz-5.x.x-x.fc32.x86_64 (you would insert your own kernel after --update-kernel by finding the vmlinuz file in your /boot directory)

If you’re able to boot from that, you can configure all kernels you have or will install in the future to use this boot flag by performing the command: sudo grubby --args="intel_iommu=on" --update-kernel=ALL

To the best of my knowledge enabling this option does not create any other problems, as hardware acceleration works just fine.


Well no, Fedora 33 didn’t work either. I guess I will have to use another distro in the future until a fix is known.