Can not login in Microsoft exchange account in Fedora 40

Hi :slight_smile:
After updating for f39 to f40, the online account don’t work. So I delete the account and then try to re-add one exchange account, but I can’t anymore.

In f39, I “remember”(not really sure) it can edit the server address while adding a new exchange account. Just a bit like this.

In f40, it looks below. :arrow_down_small: :arrow_down_small: :arrow_down_small:

After typing details in, then click “Sign in”, always get “Authentication failed”. I guess this due to the “server address” setting, because last time I add my MS account, I’ve edit server address then it works. Now there is no place for “server address”, what can I do for add my MS account back ? I really need the calendar now :cry: .

Thanks for your reading. English is not my first language, I’m sorry for any possible words make you feel offensive.

From my understanding the outlook.com accounts are personal accounts, and therefore the “Microsoft Personal” option should be chosen from the “Connect an Account” list.

Thanks for you reply.

Microsoft Personal is for mail only, no calendar or contacts, which can be integrated with Gnome Contacts/Calendar.:sob:

1 Like

News. It can pass authentication when the Domain is set as “outlook.office365.com:443”.
It looks there must something strange.

I can confirm this is letting me pass the Microsft Exchange login, however, no mail, contacts or calendars get displayed in the corresponding apps. Maybe because I’m using a personal Outlook account.

My Online Accounts setup for my Outlook account looks like this:

  • Microsoft Personal for Email
  • Microsoft 365 for Files.

Thanks for your kindly testing! :+1:

After a “System Updates” in the Gnome Software (I don’t now what actually updated), it all works now for me. It’s weird, I have to say.

1 Like