Btrfs filesystem error on second boot after fresh install

I just freshly install Fedora 37 Workstation on my laptop. First boot after installation was normal, I updated the system and installed/removed some packages, and edit /etc/fstab to automount another hard drive formatted with ntfs.

Then I reboot and it automatically went emergency mode with the error message “Cannot open access to console, the root account is locked”. After some research I suspect maybe I mistyped something with editing /etc/fstab, or ran into this known problem (Cannot open access to console, the root account is locked in emergency mode (dracut emergency shell) :: Fedora Docs) . Either way I need to boot into live usb and diagnose from there.

I first try to mount the installed system but nautilus show mounting error “can’t read superblock”, so I run the filesystem check and here’s the results:

[liveuser@localhost-live ~]$ sudo btrfs check /dev/sdb6
Opening filesystem to check…
parent transid verify failed on 63684608 wanted 223 found 222
parent transid verify failed on 63684608 wanted 223 found 222
parent transid verify failed on 63684608 wanted 223 found 222
Ignoring transid failure
Checking filesystem on /dev/sdb6
UUID: 3f84e9bd-e753-46e5-853d-2c81db60a063
[1/7] checking root items
[2/7] checking extents
[3/7] checking free space tree
[4/7] checking fs roots
[5/7] checking only csums items (without verifying data)
[6/7] checking root refs
[7/7] checking quota groups skipped (not enabled on this FS)
ERROR: transid errors in file system
found 4902719488 bytes used, error(s) found
total csum bytes: 4538064
total tree bytes: 223166464
total fs tree bytes: 204931072
total extent tree bytes: 11681792
btree space waste bytes: 45772282
file data blocks allocated: 9246724096
referenced 7446872064

I use Linux as my secondary OS for over 7 years now, have been using past few versions of Fedora, also installed Fedora 37 Beta(with ext4) and they run perfectly fine. I have no idea why such a serious filesystem error would happen on an almost freshly installed system, maybe some of you can give be some insight. I would like try repair/resolve the problem, but I can also just reinstall the system since there’s nothing important inside that filesystem.


Since that mountpoint isn’t critical to the operating system, you might want to add nofail to the list of options for the mount so that the OS will continue to boot even if it cannot mount that ntfs filesystem for whatever reason.

Could you tell me how old your PC? A drive on your PC would end of life.

That’s what I intended to do originally, but now I can’t mount the system filesystem so I can’t edit that file.

I just purchased that hard drive a year ago.

You should be able to get to a rescue prompt by adding rd.break=mount to the list of kernel parameters. Once you get to the dracut rescue prompt, you could edit that file with vi /sysroot/etc/fstab.

Edit: I see that you already stated that you cannot get to a rescue prompt because your root account is locked. :slightly_frowning_face: That is a very annoying bug in Fedora Linux. I think they may have even fixed it in more recent versions. Unfortunately, since your installation has that bug, you’ll have to make a rescue boot disk and boot from that instead.

Edit: There is another way to get to a rescue shell that might work. You could edit the kernel parameters to have rw (read-write) instead of ro (read-only) and then add init=/bin/bash. It might then boot into a shell with very limited functionality. But you should be able to edit /etc/fstab from there (using vi or maybe even nano).