Boxes instead of text in app

Suddenly all the text in flatseal has turned into boxes. I have tried restarting several times but it doesn’t change. Looks like a font issue but I don’t know what to do. Any help much appreciated.

Did you switch from the default fonts using gnome tweaks or other means?


That was it! I did change the fonts, however Flatseal worked up until a few months ago with that font (I haven’t used it for a few months). Everything else on my computer also works fine. I wonder why flatseal (only) suddenly broke?

The only thing I can think of would be that flatseal did not have access to the installed font.

You should be able to check this by adding permissions for flatseal to the font directory and changing it back.


Glad you solved this, but this probably is more like a workaround than a more fundamental solution. The squares reflect a font cache that has gone corrupt. You probably could have solved this removing the “.cache/fontconfig” directory under the “~/.var/app/com.github.tchx84.Flatseal/cache/” directory. On a subsequent launch of FlatSeal, the font cache would have been recreated.

1 Like

I found that fontconfig was in ~/.var/app/com.github.tchx84.Flatseal/cache/ rather than ~/.var/app/com.github.tchx84.Flatseal/cache/.cache

So I removed fontconfig but Flatseal still opens with boxes. I didn’t restart anything though, do I need to restart something? I avoided restarting because I’m working on some things now.

Many changes do not fully take effect until the system is restarted or the user logs out and back in. Don’t know if that applies in your case though.

Indeed, I got the path wrong. Try the same, but this time, also clear/reset your desktop font cache before starting flatseal again:

rm -rf ~/.cache/fontconfig
fc-cache -r -v
1 Like

I re-deleted ~/.var/app/com.github.tchx84.Flatseal/cache/fontconfig, did the commands from your last post and then restarted my computer. The boxes are still there. Very strange as no other program on my system has this problem. Flatseal will only work with certain fonts like serif, sans and those common ones.

which font?

Handlee regular (from Google fonts)

downloaded Handlee, and unzipped to ~/.fonts
Added a global override with Flatseal for all flatpaks to have access to ~/.fonts
Changed interface and Document text to Handlee, flatseal appears to be working.

1 Like

On my system, the fonts are in /usr/share/fonts/ Flatpak must have access to this dir as every other flatpak app displays text fine, even Flatseal was working fine up until recently. Maybe it has something to do with the upgrade from Fedora 36 to 37? Please tell me how to add a “global override” for Flatseal.

Interface is set to Handlee and Docs to a different font. I tried switching Docs to Handlee, but nothing changed with Flatseal. Thanx

1 Like

At the top of flatseal, there is an “All Applications” that allows you to set overrides for everything.

Out of curiosity does regenerating the system font cache help?

sudo fc-cache -v

1 Like

sudo fc-cache -v did nothing unfortunately. I changed the system font to sans and added to All Applications > Filesystem > Other Files ~/usr/share/fonts and the problem persists. Was this the correct way of adding a “global override” for all apps to have access to my fonts directory?

Again, try try that command after first deleting the flatseal fontconfig directory before concluding that does not work.

1 Like