Bootloader installer fails for Fedora 37 on MacBook Pro 2015 - Manjaro installs fine on the same machine

It is not solved, yet,
What you did is not different from asking people to download any different version that works, like the 37 beta, 38 beta or rawhide.

If the options from the official download page, or from fedora media writer are not working as intended, the problem is still there.

Nothing solves “itself”, people worked on it

2142968 – pyanaconda.modules.common.errors.installation.BootloaderInstallationError: Failed to set new efi boot target. This is most likely a kernel or firmware bug.
2144186 – Fedora 37 cannot be installed on Intel Macs - cannot set EFI boot target error.
2148206 – F37: Bootloader installer fails on early-mid-2010s Apple hardware

They already identified the culprit, and it seems to be fixed in the live-respins as the one you linked.

The 37 beta was problem free, so I hope it does not happen again when they release the 38.

Thank you for this. I’m trying to bring some life back to my wife’s dying 2014 macbook air and I ran into this problem. Downloaded a v36 iso from Home - MirrorManager and it seems to be working now!