Booting into the Installer: set_second_stage() failed: Invalid Parameter Something has gone seriously wrong: shim_init() failed: Invalid Parameter

Hello Fedora Community!

Let me start by saying that I love the Fedora Linux operating system and I am happily using Fedora Silverblue on my work computer.
However, booting into the installer from a USB drive does not work on my personal Fujitsu Lifebook E5510. After choosing the USB drive for boot in the boot menu, the following error appears:

set_second_stage() failed: Invalid Parameter
Something has gone seriously wrong: shim_init() failed: Invalid Parameter

It is just this text appearing in white letters on a black screen. Pressing any keys does not have any effect. After a few seconds, the notebook shuts down.

At this point, I have made the following observations:

  1. The issue is independent of the USB drive: It occurs with any USB drive when booting from my notebook. Using the same USB drives with any other computer I tried, everything works perfectly fine and I can install the Fedora Linux operating system.
  2. The issue is Fedora specific: Using the same USB drive and the same notebook with any other linux distribution I tried (Arch Linux, Ubuntu, OpenSuse, void, …) worked perfectly fine.
  3. The issue does not depend on the Fedora spin. It has occurred with any Fedora spin and also with Silverblue and Kinoite, versions 34 and 35.
    The installer for Fedora Linux 33 (I only tried the KDE spin) worked!
  4. The issue is specific to my Fujitsu Lifebook E5510 notebook: I tried installing Fedora Linux on a few other computers using the same USB drives to boot the live environment and it worked perfectly fine. The computer with the most similar hardware I tried was probably a Fujitsu Lifebook E554.

I would be very happy about some help with this issue, because I really want to use the latest versions of Fedora Silverblue also on my personal laptop. Thank you!

shim_init deals with the signed boot loader verification. Make sure your system time is set correctly in your firmware. Also, check if there are any firmware setting related to secure boot that you can try to make changes.

There is also this existing bug in bugzilla that sounds like the same issue you are having. No action has been taken on this bug yet AFAICT.

Hi, thank you so much for your reply! I added a comment to the bugzilla. At least I now have the confirmation that it is a bug and can monitor when it will be resolved.

1 Like

I want to report that this bug still affects Fedora 36 on a Fujitsu Lifebook E548.

A workaround I found is to use Ventoy to create a bootable USB drive and copy the ISO to it. I could install Fedora this way and it works flawlessly.