Boot process hangs after kernel upgrade

Hi all, apologies in advance if I’m not going about reporting this in the right way. I just upgraded my kernel from 6.7.10 to 6.7.11 this morning and was unable to reach the login screen after waiting for about 10 minutes where it normally takes a few seconds. Any idea why this might be happening? The update installed successfully. Please let me know what information would be useful in troubleshooting this issue and I’d be happy to provide it.

You can boot the new kernel without the rhgb quiet options to see where it gets stuck. You can also select the old kernel and run journalctl -b -1 to check if the system managed to generate any logs. Press F8/Space while in the POST screen to show the GRUB menu in order to edit the menu entry or select the old kernel.


I don’t use grub much anymore, but in the past you could :

Boot the new kernel without rhgb quiet options :

  1. Reboot your system.
  • When you see the GRUB boot menu, press e to edit the selected boot entry.
  • Find the line that starts with linux /boot/vmlinuz-…
  • At the end of that line, find the options rhgb quiet and remove them.
  • Press Ctrl+X or F10 to boot with the modified options.
1 Like

False alarm! I had given up and removed the new kernel earlier; when I reinstalled it, it worked without an issue. No idea what was going on the first go-around but it doesn’t seem to be an issue anymore. Thank you two for your help nonetheless! Should I mark this thread as “solved” or is there something else I should do?

1 Like

To add into this, I experienced the same “issue” and had to hard reset my system. Here’s the the last trace I had after I got tired of waiting for 10mins. The system was functional after hard reset.