Bluetooth was skipped because of a failed condition check

Guys, this is serious. After 3 weeks of inactivity on my fresh Fedora 37 my bleutooth no longer works and I can’t connect my wireless keyboard to do my work. I googled it and found some answers here on ask fedora suggesting to do dnf upgrade which I did but bleutooth still doesn’t work. It says Bluetooth was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth) I didn’t do anything, it just stopped working. This is ridiculous. I can’t connect my MX Logitech keyboard to even get into BIOS. After 3 weeks of inactivity suddenly everything stops working? Please, what is going on here? Can someone help me out?

dmesg | grep bluetooth

Returns nothing.
It used to work just fine and it suddenly stoped working by itself?


doesn’t return anything related to bluetooth.
I want to mention that the keyboard does work on my TV and Macbook while the dongle is still connected to my PC.

You definitely would help giving more info’s about your system.

If you could read then you would have known that I use Fedora 37 fresh install. I wrote it in my second sentence in my post.

My system not just contains a linux version, it has a keyboard version, it has a Desktop Environment it also contains a mouse with a model number etc.

I’m able to read in the tag you have F36 and in your sentences F37 :grin:

I don’t know anything about tags, I didn’t set it. Well, not only you can’t read but also can’t ask questions. How about asking more specific question such as “What version of the system are you running?” Or “What desktop environment are you running?” What do you expect from me? To read in your mind? Anyway, I also mentioned in my post that I have Logitech MX keys, you missed this, too. Also, what does desktop environment have to do with bluetooth? Nothing. So please, if you feel capable helping me out then please do, otherwise you’re making things worse.

I remember something about Bluetooth being disabled during an update. Strangely enough, but not for everyone.

Try to determine the status:

systemctl status bluetooth

Followed by Ctrl+C for a new prompt.

If not active:

sudo systemctl start bluetooth

sudo systemctl enable bluetooth

I hope this helps.

systemctl status bluetooth

It’s enabled but it’s inactive(dead) Bluetooth was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth)

I already tried

sudo systemctl start bluetooth
sudo systemctl enable bluetooth

without luck.

The requested system information is still missing.

inxi -F

would be good.

Have you already done a clean reboot?
How can you log in now without keyboard?
Tried deleting the device from the list and pairing it again in the desktop?

Yes, I have rebooted hundreds of times. I can login using onscreen keyboard… THERE ARE NO DEVICES BECAUSE BLUETOOTH DOESN’T WORK!!! When I click on Bluetooth in Settings it says No Bluetooth Found while my keyboard dongle is connected to USB port. I can see it is loaded at boot

dmesg | grep logitech

[    2.312421] logitech-djreceiver 0003:046D:C52B.0006: hiddev98,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-13/input2
[    2.538302] logitech-hidpp-device 0003:046D:408A.0007: input,hidraw4: USB HID v1.11 Keyboard [Logitech MX Keys] on usb-0000:00:14.0-13/input2:1
inxi -F

  Host: fedora Kernel: 6.0.15-300.fc37.x86_64 arch: x86_64 bits: 64 Console: pty pts/1
    Distro: Fedora release 37 (Thirty Seven)
  Type: Desktop Mobo: Gigabyte model: Z97-HD3 v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F10c date: 03/03/2016
  Info: quad core model: Intel Core i5-4690K bits: 64 type: MCP cache: L2: 1024 KiB
  Speed (MHz): avg: 1124 min/max: 800/3900 cores: 1: 2098 2: 800 3: 800 4: 800
  Device-1: NVIDIA GM204 [GeForce GTX 970] driver: nvidia v: 525.60.11
  Display: server: v: 1.20.14 with: Xwayland v: 22.1.7 driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia,nvidia-nvswitch tty: 214x48 resolution:
    1: 2560x1440 2: 2560x1440
  API: OpenGL Message: GL data unavailable in console. Try -G --display
  Device-1: Intel 9 Series Family HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GM204 High Definition Audio driver: snd_hda_intel
  Device-3: Logitech Blue Microphones type: USB driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.15-300.fc37.x86_64 running: yes
  Sound Server-1: PipeWire v: 0.3.63 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 74:d4:35:b7:c0:58
  Local Storage: total: 1.71 TiB used: 9.58 GiB (0.5%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
  ID-3: /dev/sdc vendor: Toshiba model: HDWJ110 size: 931.51 GiB
  ID-4: /dev/sdd vendor: Samsung model: SSD 840 PRO Series size: 119.24 GiB
  ID-1: / size: 231.3 GiB used: 9.3 GiB (4.0%) fs: btrfs dev: /dev/sdb3
  ID-2: /boot size: 973.4 MiB used: 268.7 MiB (27.6%) fs: ext4 dev: /dev/sdb2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat dev: /dev/sdb1
  ID-4: /home size: 231.3 GiB used: 9.3 GiB (4.0%) fs: btrfs dev: /dev/sdb3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 37 C
  Fan Speeds (RPM): N/A
  Processes: 256 Uptime: 9m Memory: 15.55 GiB used: 1.69 GiB (10.9%) Init: systemd
  target: graphical (5) Shell: Zsh inxi: 3.3.24

Please keep cool. Writing capital/bold letters in a Forum means you are screaming. Please be friendly in the end we just try to help.

It is very difficult to be calm when I write something and the other side doesn’t read it. I have a serious problem and if this is meant to be the official Fedora forum then I expect the other side to be helpful as well. You are not the only side who has expectations.

It isn’t that we do not read. It is that we do not have the information needed to be able to assist.

You said you have a Logitech MX keyboard connected by bluetooth. Is that the only possible way of connecting that keyboard? The specs show no.

The specs for your keyboard state that it is bluetooth or lbolt receiver connected. If you use the included lbolt receiver plugged into a USB port it avoids the bluetooth issue while you track down and fix that problem.

There is no reason to be upset, simply calmly explain things and ask reasonable questions while we work through finding the cause.

Once you have a functioning system with a keyboard that works we can provide instructions to aid in solving the bluetooth problem. This may even require using a different keyboard that does not use bluetooth should you no longer have the included lbolt receiver.

Personally I would never expect to get into the bios with a bluetooth keyboard. Bluetooth drivers are never loaded until after the kernel is loaded during boot, so bios cannot be accessed with a bluetooth device.

If the lbolt receiver is anything like the logitech unifying receiver the system sees it as a purely USB device and this is never an issue because the bios recognizes it and my K350 keyboard and MX mouse work for me in bios.

Yes, my Logitech MX Keys keyboard has a dongle which I keep connected to a USB port. It used to work just fine. This is the keyboard that has it’s own receiver so the system sees it in BIOS but the problem is that in order to pair it to work with my PC I need to go to Settings → Bluetooth and add it there but Bluetooth doesn’t work, it says there are no devices even when my receiver is connected to USB port.

It looks like that you use a Bluetooth dongle just for bluetooth? right? And a other dongle for your keyboard?

If first is yes, what dongle are you using ? Check with lsusb

No, I have a Logitech receiver, which is USB device and in order to pair it you need to go to Blutooth settings and enter the number that appears on the screen but the problem is that bluetooth device is down. It should look like on the screen below.

Ok, so that does not seem to be keyboard related at all (at least not directly) but an issue with bluetooth on the system.

Please run rfkill and post the output here. Use the Preformatted text </> tags from the toolbar to retain formatting.
Also run lspci -nn and post that output.

Remember that to avoid device conflict once bluetooth is enabled again that you should not connect the same device in 2 different ways.

Since Bluetooth does not show up in inxi, I’ll save myself further questions.
So it can only be Bluez or a general driver problem.
But since I still do not know the DE?
Also ‘’‘bluetoothctl’‘’ falls away because the adapter is not recognized.

rfkill doesn’t return anything

jedrek@fedora:~ ➜ sudo rfkill
jedrek@fedora:~ ➜
lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 4th Gen Core Processor DRAM Controller [8086:0c00] (rev 06)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller [8086:0c01] (rev 06)
00:14.0 USB controller [0c03]: Intel Corporation 9 Series Chipset Family USB xHCI Controller [8086:8cb1]
00:16.0 Communication controller [0780]: Intel Corporation 9 Series Chipset Family ME Interface #1 [8086:8cba]
00:1a.0 USB controller [0c03]: Intel Corporation 9 Series Chipset Family USB EHCI Controller #2 [8086:8cad]
00:1b.0 Audio device [0403]: Intel Corporation 9 Series Chipset Family HD Audio Controller [8086:8ca0]
00:1c.0 PCI bridge [0604]: Intel Corporation 9 Series Chipset Family PCI Express Root Port 1 [8086:8c90] (rev d0)
00:1c.2 PCI bridge [0604]: Intel Corporation 9 Series Chipset Family PCI Express Root Port 3 [8086:8c94] (rev d0)
00:1c.3 PCI bridge [0604]: Intel Corporation 9 Series Chipset Family PCI Express Root Port 4 [8086:8c96] (rev d0)
00:1d.0 USB controller [0c03]: Intel Corporation 9 Series Chipset Family USB EHCI Controller #1 [8086:8ca6]
00:1f.0 ISA bridge [0601]: Intel Corporation Z97 Chipset LPC Controller [8086:8cc4]
00:1f.2 SATA controller [0106]: Intel Corporation 9 Series Chipset Family SATA Controller [AHCI Mode] [8086:8c82]
00:1f.3 SMBus [0c05]: Intel Corporation 9 Series Chipset Family SMBus Controller [8086:8ca2]
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM204 [GeForce GTX 970] [10de:13c2] (rev a1)
01:00.1 Audio device [0403]: NVIDIA Corporation GM204 High Definition Audio Controller [10de:0fbb] (rev a1)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
04:00.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 41)

I connected my bluetooth USB dongle and I was able to pair my keyboard using bluetooth but that’s not what I want because I used to use the wireless logitech receiver included in the keyboard, not bluetooth. When I connect my keyboard using buetooth the keyboard doesn’t work in BIOS nor in bootloader and I want to get into BIOS. It used to work in BIOS and bootloader before. I have logitech unifying receiver

Do you have more than one unifying receiver? Then you might check if your keyboard is paired with both of them.

Is the battery of your motherboard ok? If you enter in bios with a wired keyboard, are the settings you made stored correctly ore do you loose some settings? If you loose settings it is might time to change the battery of your Motherboard.