Bluetooth Mic very jittery after latest updates


I have a set of Bose NC 700 Headphones that I have been using with Fedora since 2019. For the most part, they have always worked quite well.

The headphones are Bluetooth and have a microphone.

With a recent update, the microphone became unusable. It is very jittery (I would describe it as micro jitter). I have been trying a lot of things, and once after a fresh reboot, the mic worked normally until I changed to another mic and then back again. It then reverted back to poor quality jitter again. The headphones work normally connected to my phone, so I don’t think this is a hardware issue.

This happened after updates including the following: (I assume this has to do with pipewire)
Upgrade pipewire-0.3.53-2.fc36.x86_64 @updates
Upgraded pipewire-0.3.52-4.fc36.x86_64 @@System
Upgrade pipewire-alsa-0.3.53-2.fc36.x86_64 @updates
Upgraded pipewire-alsa-0.3.52-4.fc36.x86_64 @@System
Upgrade pipewire-gstreamer-0.3.53-2.fc36.x86_64 @updates
Upgraded pipewire-gstreamer-0.3.52-4.fc36.x86_64 @@System
Upgrade pipewire-jack-audio-connection-kit-0.3.53-2.fc36.x86_64 @updates
Upgraded pipewire-jack-audio-connection-kit-0.3.52-4.fc36.x86_64 @@System
Upgrade pipewire-libs-0.3.53-2.fc36.x86_64 fresh @updates
Upgraded pipewire-libs-0.3.52-4.fc36.x86_64 @@System
Upgrade pipewire-pulseaudio-0.3.53-2.fc36.x86_64 @updates
Upgraded pipewire-pulseaudio-0.3.52-4.fc36.x86_64 @@System
Upgrade pipewire-utils-0.3.53-2.fc36.x86_64 @updates
Upgraded pipewire-utils-0.3.52-4.fc36.x86_64 @@System

The kernel was updated at the same time:
Install kernel-5.18.9-200.fc36.x86_64 @updates
Install kernel-core-5.18.9-200.fc36.x86_64 @updates
Install kernel-devel-5.18.9-200.fc36.x86_64 @updates
Install kernel-modules-5.18.9-200.fc36.x86_64 @updates
Install kernel-modules-extra-5.18.9-200.fc36.x86_64 @updates

I am looking for pointers on how to trouble shoot this issue. I have not rolled back this update to verify it goes away. Was hoping to troubleshoot the issue and move forward.


I would assume you have rebooted since the upgrade, so you should be running with kernel 5.18.9 and pipewire 3.53-2

Have you tried booting in the older kernel to see if it may be kernel related or is strictly audio related?

Luckily that update only updated the kernel and pipewire so it seems that one of the two would be the cause.

My approach would be older kernel with newer pipewire. If that does not solve it then you are left with rolling pipewire back to 3.52-4 and trying both the newer kernel and the older kernel to find out which mode works (and more specifically what fails).

Once you have confirmed a specific combination that works and what fails then a bug should be filed as a regression on the offending package(s).

Same problem here. I’m using Shokz OpenRun via Bluetooth. Very jittery.

same here with my Jabra Evolve 65 Bluetooth (HSP/HFP, codec mSBC) Headset.

I tested it with kernel 5.18.5 and the error is the same as with 5.18.9.

I then tested a current Fedora live environment (by Index of /pub/alt/live-respins): The error does not occur with it.

So maybe it has something to do with the configuration on the machine? I remember that I installed the following gnome-extension at about the time of the failure: GitHub - MichalW/gnome-bluetooth-battery-indicator: Gnome-Shell extension displaying battery percentage for bluetooth devices

I reversed the installation (sudo dnf history undo x) but also without success. I also deleted /var/lib/bluetooth. No solution either.

My issue definitely was isolated to the system update.

I have a feeling that it is a local setting issue since I can randomly get it to work correctly after a reboot, but it doesn’t last long. Soon as I do something to cause the mic to switch away, the jitter returns.

I have the same issue after recent update on different headsets (Avantree Aria Podio, Jabra Elite 7 Pro) and on different codecs (CVSD, mSBC, FastStream Duplex).

I tried booting into older kernel 5.17.13-300, and the issue still persists.

So I think it is related to pipewire update. I will try downgrading it to see if it helps.

I just updated to newer pipewire 0.3.54, and the issue was fixed and went away.

Looks like they made a bug and hotfixed it, and the update is already available in Fedora: 0.3.54 · PipeWire/pipewire@752afa0 · GitHub


yes! Updating pipewire did the trick also in my case.


Update worked for me!