Bluetooth headset can connect, but no sound output/input

After each Fedora upgrade (like last Fedora 35 time) I already expect Bluetooth/audio issues.
So here we go…

First a funny bug

The name of the one headset I use is not visible in GNOME Settings… :upside_down_face:

bluetoothctl has no problems showing it though:

$ bluetoothctl 
Agent registered
[bluetooth]# devices
Device B0:67:2F:1B:**:** PX7 Bowers & Wilkins

Maybe the & is breaking stuff here?

Anyway, I can still click on it and then it is shown/works as usual:

The problem

I can also connect the device, the connection is confirmed by the devcie and that all works.
Only, it does not show up as an audio device – nor as input (though that was broken in Fedora 35 as well – I mean it showed up, but was not usable) or output.


Workarounds tried

  • rebooting
  • unpairing and repariing (with GNOME Settings)


I should possibly note sth. about my system.

I followed the usual guides for having aptX support, I guess in Fedora 34 already.

That’s also why I have removed some base packages… maybe there is a problem with these?
That has been suggested to me at the time of the Fedora 35 upgrade and worked fine so far in F35.

$ rpm-ostree status -v
State: idle
AutomaticUpdates: stage; rpm-ostreed-automatic.timer: last run 5h 54min ago
● fedora:fedora/36/x86_64/silverblue
                   Version: 36.20220512.1 (2022-05-12T20:00:12Z)
                BaseCommit: 298486a9757785902e07482e5a71008e521e9d1c92d7a98e6bc25ac53c966f9f
                            ├─ repo-0 (2022-05-04T21:16:11Z)
                            ├─ repo-1 (2022-05-12T19:35:04Z)
                            └─ repo-2 (2022-05-12T19:36:45Z)
                    Commit: 823c7b3d3d4af36293ea6d2a3c7635e8bacbdb0692b6296f7546446b5fd78a13
                            ├─ fedora-modular (2022-05-04T21:12:01Z)
                            ├─ fedora (2022-05-04T21:16:11Z)
                            ├─ rpmfusion-free (2022-05-04T04:48:11Z)
                            ├─ fedora-cisco-openh264 (2022-04-07T16:52:38Z)
                            ├─ updates (2022-05-13T01:50:57Z)
                            ├─ rpmfusion-free-updates (2022-05-09T05:15:49Z)
                            ├─ updates-modular (2022-05-08T01:14:17Z)
                            └─ updates-archive (2022-05-12T20:41:38Z)
                    Staged: no
                 StateRoot: fedora
              GPGSignature: 1 signature
                            Signature made Do 12 Mai 2022 22:00:44 CEST using RSA key ID 999F7CBF38AB71F4
                            Good signature from "Fedora <>"
       RemovedBasePackages: pipewire-pulseaudio 0.3.51-1.fc36 wireplumber 0.4.9-1.fc36
           LayeredPackages: adb compat-ffmpeg28 dconf-editor firewall-config git git-credential-libsecret git-subtree gnome-tweaks gstreamer1-plugin-openh264 gtkhash-nautilus heimdall htop
                            httpie keepassxc kid3 lshw mozilla-openh264 nautilus-image-converter nextcloud-client nextcloud-client-nautilus nvme-cli openssl pipewire-media-session
                            podman-compose rpmfusion-free-release simple-scan smartmontools sushi tldr zsh

Now reported this as a bug, it seems to be clearly related to the ampersand (&):

Okay the issue really stems from trying to enable aptX support, which was only available with legacy audio stuff.

Because if I remove/reset the overrides (of pipewire-pulseaudio wireplumber), it works. I only have A2DP/AAC codec then, which makes it impossible to use for input and output of audio (as the bandwidth is way too small).

Thankfully I found a solution using the new wireplumber, because rpm-fusion now apparently has a wireplumber-aptx plugin that is even easier to use than before! No overrides needed anymore!

After you have added rpmfusion as usual, it is as easy as doing:

rpm-ostree install pipewire-codec-aptx

That’s it! Now you can use aptX.

(That said, I can still not use the headet as an input device at the same time, as the codec then automatically switches to very ugly HSP/HFP/mSBC but at least it works as it worked in F35, great!)

Okay, so let’s split that from this discussion. I’ve created a new thread for that issue itself: