Bluetooth can't be enabled

I’m using Nobara 37, with the kernel 6.1.14.
I have an Asus B550 F gaming.
The command inxi returns:

  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 05:00.0
  IF: wlp5s0 state: up mac: <filter>
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    port: N/A bus-ID: 06:00.0
  IF: enp6s0 state: down mac: <filter>
systemctl status bluetooth
○ bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: enabled)
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

mars 06 20:24:09 nobasus systemd[1]: bluetooth.service - Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
inxi -xE
  Message: No bluetooth data found.

On others distro, bluetooth works fine.
I think it’s a driver problem, maybe should I use that Linux* Support for Intel® Wireless Adapters ?

Please, help me

Found this which might be useful: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth) - Support - Manjaro Linux Forum

Try searching for any option on your BIOS that allows you to have a fast boot by skipping initialization of some unneeded devices, then either disable it or set it to full more.

Tks, but I already try that. Also, I tested other distro and bluetooth seems to not works either. I think it’s because I removed my dual-boot with Windows recently. I don’t know if a bios update could help. Or maybe sould I just reinstall Windows :frowning:

Edit: I also tried to extract iwlwifi-cc-46.3cfab8da.0.tgz inside /lib/firmware and reboot but nothing change.

is it working in Fedora Linux?

Ok so I tested absolutely everything:

  • with Fedora
  • reinstall Windows
  • update my bios
  • try the drivers only available on Windows

And nothing that worked.
I just came across a Redit post that talks about a static electricity issue. I tried, telling myself that it was really a waste of time, and … it actually worked! I will update this when I reinstall Fedora, or Nobara.