Bluetooth cannot find any devices

When I go to bluetooth settings, no devices are ever shown. It says “searching for devices…” forever.

Output from running hciconfig:

hci0:	Type: Primary  Bus: USB
	BD Address: 40:EC:99:BA:B1:3D  ACL MTU: 1021:4  SCO MTU: 96:6
	RX bytes:6887 acl:0 sco:0 events:912 errors:0
	TX bytes:16629 acl:0 sco:0 commands:806 errors:0

Try creating file /etc/bluetooth/main.conf with contents:


Reboot. Then see if the device is detected.

1 Like

Hello and thanks for your response.
I took a look at that file and it already had the AutoEnable=true. I found some documentation you linked to in a similar forum and tried adding

load-module module-bluetooth-policy
load-module module-bluetooth-discover

to /etc/pulse/ and rebooted. After that, the bluetooth device was discovered for the first time, but when I clicked on it to pair it, it disappeared. It’s back to saying “Searching for devices…”.

1 Like

Well, that is progress.

My next suggestion is to follow the CLI pairing instructions from the Arch Linux Wiki:

1 Like

I am assuming the computer is the Dell XPS 13. What is the Spin? In other words, is it Workstation (gnome3), Cinnamon, KDE, etc. What is the device you are trying to connect to your Dell XPS 13?

Whenever I try to connect device with Bluetooth, I have to make sure the Bluetooth is on before opening the Bluetooth settings. Again, make sure Bluetooth is already on before opening Bluetooth settings. Sounds weird, but that is what I usually have to do. So, step (1) turn on the Bluetooth, step (2) exit out of Bluetooth settings, step (3) press the pairing button on the device you want connected, step (4) open Bluetooth settings, step (5) the device should populate, but if it does not, make sure it cannot connect to any other devices. For example, if I want to connect my headphone to my computer, if my phone Bluetooth is not off, it will connect to my phone before my computer has a chance. step (6) after the device populates, pair it with your computer.

I know, you probably already tried all this, but it is worth mentioning because this is usually what happens to me when I try to connect Bluetooth.

Yeah, that was the documentation I found. Here’s the output from bluetoothctl

[brian@dell-xps-13 ~]$ bluetoothctl 
Agent registered
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# devices
[bluetooth]# scan on
Discovery started
[bluetooth]# agent on
Agent is already registered
[bluetooth]# devices

Yes, it is a Dell XPS 13 and I’m using the workspace version. I’m trying to connect earbuds to the laptop, specifically Beben X8 earbuds.
I tried making sure bluetooth was on before opening bluetooth settings, but it acted the same. The laptop discovers the earbuds - only the earbuds, not my phone for example - but when I try to pair them, the earbuds go away and are never discovered again.

If you haven’t checked this yet, what Bluetooth version is running on your laptop? The user manual says that Bluetooth 4.0 or higher is required.

Also, here is the link to some debugging things you can try. How to debug Bluetooth problems - Fedora Project Wiki

One more thing, as I mentioned before, try making sure the Bluetooth is turned off on your phone and any other device that is near by. Only the Bluetooth on your computer should be turned on. Then try connecting your headphones. Do simple troubleshooting methods like: (1) Turn off the headphones (should be about 4 seconds of pressing the button), (2) turn on the headphones (should be about 2 seconds of pressing the button), (3) make sure both ear-buds are turned on and paired to each other, (4) turn off computers bluetooh, (5) turn on computers bluetooth, (6) with both the computer bluetooth and both ear-buds on, try pairing it with your computer. Again, make sure that there are no other devices that have bluetooh turned on. If you ever paired your ear-buds to your phones, it will not pair to the computer. You must turn your phones bluetooth off or delete the saved pairing in your phone and then turn your phone bluetooth off.

If it still does not work after messing around with some of those troubleshooting methods, try resetting your ear buds. While the earbuds are charging (solid white lights), hold both power buttons for 5 seconds or until the blue/white lights flash 3 times and turn off. Then take the buds out and put them back in the charging case. Make sure you delete any saved pairing from your phone or other devices. Then to activate them, take out the left earbud first, then the other. Then try connecting your earbuds to the computer.

But, this is all assuming that the Dell XPS 13 has bluetooth 4.0 or higher.

Hi, Kulani

Thanks for the suggestions. My computer has bluetooth 5.1. I tried the steps you mentioned, but they didn’t work. I also couldn’t get resetting the earbuds to work.

I’ve tried a bunch of different stuff, including updating the firmware in /lib/firmware/intel/, but nothing worked. I dual boot windows, so I tried to connect them there, but it still didn’t work.

After messing around with it a bit more, I discovered that as long as the earbuds are very close to the laptop - like an inch or two away - it will connect and work. If I put the earbuds in my ears while I’m sitting at my computer, the connection is lost. I am able to connect the earbuds to my phone and they work up to about 30 feet.

The only other thing I could say to do, besides getting new ear buds, would be to see if you can connect some other Bluetooth device to your laptop. By doing this, we can at least eliminate the laptop as the problem.

You can try connecting your phone to your computer. I literally just got up and did that with another computer I have Fedora 32 XFCE spin. It immediately found my phone and I paired it. A pop-up displaying a number to confirm that this is the correct device appeared on both the laptop and my phone.

Now, if you cannot get your phone to connect to the laptop, then try reinstalling Fedora 32, and/or a different Spin of Fedora.

That is the last thing I can recommend before it just starts to get redundant.

That sounds like the computer has a bad bluetooth antenna/radio. I have had some cases where I needed to disable the built-in bluetooth and install an add-on card/dongle to make the computer bluetooth able to work.

1 Like

I have tried all these above methods. Still the Bluetooth not able to find any device or other devices can see it. However the Bluetooth is on.