Blink-based browsers don't open file dialog in sway (fedora 38)

I have two machines that have recently been re-installed from scratch to run fedora 38. On my WFH machine, I installed workstation, tried a couple of different X11 DE’s and Wayland compositors, and settled on sway. On my personal machine I installed later, and used Sericea.

On my WFH machine, blink-based browsers (Brave, chromium, ungoogled-chromium) can’t open file dialogs in sway. Ctrl±o does nothing. Right clicking on an image or link, and selecting “Save link|image as” does nothing. File dialogs open fine on my Sericea sway desktop, and blink-based browsers work fine on my WFH machine under GNOME (X11 or Wayland) and Budgie. Just not with sway.

I’ve searched around, and maybe this is related to xdg-desktop-portal-(gnome|gtk|wlr). But I don’t really know what those are or what would be a good next step to troubleshoot.

ETA: I forgot to mention that the first thing I tried was:

mv ~/.config/sway ~/.config/sway.tmp

exited sway, and logged back in to a default config. File dialogs still didn’t work, so I’m reasonably sure this isn’t a problem with my personal sway configuration.

ETA2: My memory sucks. My WFH machine was installed with Fedora 36 in Aug 2022. It’s been upgraded to 37, then 38. My personal machine was installed from scratch with Sericea 38.

Same problem here, I’ve been using ungoogled Chromium for a year now without problems with the command line: --enable-features=VaapiVideoDecoder,WebRTCPipeWireCapturer --ozone-platform=wayland

Since few weeks, I’m not sure when it started, the open file dialog doesn’t work anymore, just to mention few examples: doing right click + “Save As” on a link does nothing andI cannot export my bookmarks.
Firefox works correctly.
I’m on Fedora 38 running Sway 1.8.1-1.fc38 and I tried the following browsers:

  • com.github.Eloston.UngoogledChromium 116.0.5845.140 from flatpak
  • google-chrome-stable-117.0.5938.88-1.x86_64
  • 117.0.2045.35-1 from flatpak

Good to know I’m not the only one. I wish I knew when it started, also, but I only use brave or ungoogled chromium for Microsoft Office/Teams (shudder), so I think I just blamed it on Teams for a long time.

brave-browser-1.58.129-1.x86_64 (rpm)
com.github.Eloston.UngoogledChromium 117.0.5938.88 stable flathub user

I had the same issue, I fixed it by adding sway to UseIn in /usr/share/xdg-desktop-portal/portals/gtk.portal

without this config there is no dbus interface org.freedesktop.impl.portal.FileChooser

not sure what should be the default interface for sway or how it was working previously

1 Like

@bengentil this fixed the problem for me, thank you very much for the advice!

if you want to add any details or follow its resolution, if filed this bug report: 2241173 – File chooser dialog is not showing with sway

That worked for me, also. Thank you, @bengentil ! I would have gotten there eventually, but you saved me a lot of time. I’m no DBUS or xdg-desktop-portal expert.

For anyone as inexperienced as me, here are the details of the change I made

In /usr/share/xdg-desktop-portal/portals/gtk.portal I had this line originally:


I sudo vied that file and changed the UseIn line to:


Then I logged out of sway, and logged back in, and Ctrl+o popped up a file dialog in chromium.

1 Like