Auto Start a mount not working adding OneDrive with Rclone but Fedora 36 not happy

HI Guys

I am trying to auto mount OneDrive in |fedora 36 and it does not like the file i have done.

But as a semi noob it looks ok to me would appreciate some help why it is not working.

I just moved over from Zorin and it worked a treat in Ubuntu but Fedora does not have a way in the GUI to add OneDrive so i added this file to .config/autostart folder onedrive.desktop (see below)

But Fedora does not like it the boot takes about 3 min compared to 30 seconds.

ALso when i get it things do not load and the terminal is very weird reporting issues with it but i cannot capture what it says

[Desktop Entry]

Name=One Drive

GenericName=File Synchronizer

Exec=sh -c “rclone --vfs-cache-mode writes mount "onedrive": ~/onedrive”







When i check logs i see this, any ideas why i am not able to mount please

Look here and all your questions are answered. I use it for many years now over different distros, no issues and so easy to use. Don’t forget to install onedrive from the Fedora Repos. :grinning:

1 Like

Cheers so are you saying forget rclone and use this ?

Yes. I recommend onedrive for its reliabilty.

I removed rclone and went to install the latest fedora release i am on Fedora 36.
Soon as i try to install it errors

I tried searching for packages nothing found

Any idea how to fix or is it a bug?

Did you try to install that directly from fedora or with an rpm from onedrive?

On Fedora 36 I did this and it seems to work.

]# dnf install onedrive
Last metadata expiration check: 1:02:48 ago on Tue 09 Aug 2022 02:41:14 PM CDT.
Dependencies resolved.
 Package                   Architecture            Version                          Repository                Size
 onedrive                  x86_64                  2.4.19-1.fc36                    updates                  680 k
Installing dependencies:
 ldc-libs                  x86_64                  1:1.27.1-3.fc36                  updates                  2.4 M

Transaction Summary
Install  2 Packages

Total size: 3.1 M
Total download size: 680 k
Installed size: 16 M
Is this ok [y/N]: 

Not sure why it would not work for you if installing directly from the fedora repo.

So run these then install?

If so would his have any impact on future updates?
Also in creating new links could it break other apps that need these as dependencies?

I did an update to my post above.

HI Jeff
I downloaded the rpm directly from the site here
Then tried to install from

HI just tried from repo it worked cheers.

Can you view the Ondrive only in terminal or can you see in File Manger?

3rd party sources often have issues with dependencies and updates.

I suggest you follow what @heliosstyx recommended and simply install onedrive with dnf from the fedora repo. It should pull in the needed dependency and just work.

I do not use it so cannot answer. Try it.

1 Like

I run a dry run this morning i was running for hours in a loop doing the same stuff.
I have added this sync-list file again took 30 plus minutes looping same items
But produces an error
ERROR: Microsoft OneDrive API returned an error with the following message:
Error Message: HTTP request returned status code 500 (Internal Server Error)
Error Reason: Failed to get a coherent view of changes. Try again later.
Error Timestamp: 2022-08-10T09:30:12
API Request ID: bcf2573e-6485-4743-a752-3353203811a5
Calling Function: applyDifferences()

Could you also tell me where the OneDrive config file is located because it is not in the default place .config/onedrive folder where i would expect it.