Authenticate with password in "Authentication Required" prompt

Is there a way to authenticate with password when this prompt appear?
I do have a fingerprint reader but sometimes I use the laptop with KVM attached and laptop completely closed, so no fingerprint access.

authenticate

It looks to me like that is a dedicated popup. I don’t use a fingerprint and it always asks for password. Since you appear to prefer the fingerprint reader it asks for that.

I am sure there is a way to modify that, but I have not dug into things that far. Possibly the lid switch could disable the fingerprint reader so it asks for password instead.

Yes but I think there should always be a fallback method!

@cirelli94 Did you figure out if there’s a way to use the password instead?

type ctrl+c I think that works

That doesn’t do anything for me, unfortunately.

I would try authselect command, see man for details.

1 Like

@towadroid Unfortunately, no.
@boredsquirrel that works only in a shell, e.g.:

$ sudo su
Place your finger on the fingerprint reader
^C[sudo] password for cirelli:

As you can see, here above I did a CTRL+C when asked for the fingerprint and it asked the password in the “old” way!

It worked for me… I think?

But a FR for the password dialogs for GNOME and KDE to have a button “use password” would make sense. Pretty sure that would be “too bloated” for GNOME though.

I found out that an issue has been created about a year ago on the gnome repo (see here).

@boredsquirrel We somehow must be talking about different things. The issue also states that a simple Ctrl+C currently does not work.

2 Likes

pam_fprintd(8) says:

timeout= TIMEOUT
The amount of time before returning an authentication failure. The default timeout is 30 seconds, with 10 seconds being the minimum.

So you could wait 30 seconds and it will switch over to a password prompt automatically. I tested this with both sudo in a shell and also a graphical password prompt triggered via pkexec.
If that’s too long, reducing it to 10 seconds sounds to me like a good tradeoff between the time I need for finding my fingers and waiting for a timeout deliberately.

If I remember correctly click authenticate and it will give password prompt I might of used this one sometimes when I use lid closed and before I bought external finger print reader on desk

Sadly clicking “Authenticate” does nothing for me. In fact I’m not quite sure it does anything at all, it just confuses me

That’s a very nice workaround @alina0xff , thanks a lot!
Have you already set it?
I can’t wrap my head around how to set that config :confused:

I see there are the settings in /etc/pam.d/system-auth but should be changed with authselect which I can’t get to work properly :man_facepalming:

But clicking cancel activates Password authentication just tested today

Did you change settings? Is this a GNOME UI component? If so, we might be able to raise the issue there.

Nope, for me it close the overlay window.