Audio not working - No output devices nothing - Using external devices doesn't work

All of the sudden after yesterday audio has stopped working. It seems that their are not input nor output devices. I attach a paste bin to alsa logs( --no-upload) and show how it looks in gnome. Thank you!!

Basically their is only dummy output testing it results in settings not responding and having to force close it. I have also tried connecting a headphones and bluetooth headphones but no success.

First, try shutting down completely and booting, in case it’s some kind of power management issue or random failure.

I’m guessing you updated yesterday because you’re on kernel 6.2.10 which was pushed about 2 days ago.

You could try using a previous kernel. Reboot and hold the Shift key when the manufacturer’s screen appears, then select the second option (assuming the first is 6.2.10).

If that doesn’t resolve it, I’d like to see the output of pactl list. You can upload it to the same pastebin, or use Fedora’s pastebin:

$ pactl list | fpaste

What devices do you use: do you want output to HDMI with TV or a monitor with speakers, laptop internal speakers, or headphones?. Is input a laptop built-in mike, headset mike, etc.?
the output you asked

It is a laptop with builtin speakers which was working fine till as I mentioned 2 days ago now. Nothing works now that is no hdmi, using wired headphones or bluetooth audio. No input no output

I found a few reports on Reddit yesterday that pipewire 0.3.69 caused complete loss of audio devices.

If booting a previous kernel didn’t work, then try downgrading pipewire.

This will downgrade to pipewire 0.3.59 from F37 release:

$ sudo dnf downgrade pipewire

Reboot after downgrading.

You can check the current running version of pipewire:

$ pipewire --version

Thanks Justin downgrading pipewire to 0.3.59 did the trick for me. Hopefully it gets fixed soon. I’ll stay tuned. Thank you very much

1 Like

@abdulee Has pipewire 0.3.70 fixed the issue for you?