Are there no choices anymore between headset and audioset when plugging a device? How can we fix this?

Hi there! I’ve used a lot Fedora on other computers, and always seen a pop-up window when plugging my earphones, asking if I just wanted to activate the audio set or the mic too.
On my new computer though, there is no such pop-up, and the mic is always active…
Does anyone know how to fix it?
Many thanks in advance!

:thinking: I’m not sure, but I believe each sound cards have different audio codecs and profile except if we connect with active headset devices that have their codecs and profiles on their own.

I 2 headset, one passive and the other is active. The passive one will only follow what available profiles and codecs from my laptop sound card and the other have their own profile and codecs when connecting it to the laptop.

You could check on Gnome Settings → Sounds → then below Output Device (between Output Device and Volume) if there any other profile presented. If it not, you’ll only have the current profile.

Thank you for your quick answer. The community and the ethics of Fedora are so enjoyable.
Updates to my post after yours Syaifur Rizal:

  • I’ve already used the same headset on the same Fedora version on a very similar computer with the same sound card, and I’ve always seen that very useful pop-up. I miss it because it always reminded me to cut the mic when necessary.
  • Choosing when connecting a headset either to use it for the audio or the mic too is a very basic fonction on Fedora and any OS (Linux, IOS, Windows). I know I’m missing something, and I’ll be very happy when resolving that. It’s really annoying to always have to check if the microphone is open or not.
    Does someone have an idea to fix it?

I don’t know how to change it, but most persons using a headset wish the headset mic to be active so that is likely the reason it is done as default. I love the fact that my headset is fully active without having to change any settings.

I suspect that you would need to communicate with the pipewire or wireplumber developers if you want that popup to be restored since it is likely that the switch from pulseaudio to pipewire is what triggered the change and that little feature may have been overlooked.

Thanks for your answer Jeff!

I really doubt it though, for the following reasons:

  • Choosing between activating or not the mic when connecting the device is a very basic thing on all OS. I don’t think it’s a little feature, but an important one - discrete indeed - but very useful tool. Unseen when there, but very missed when not.
  • I’ve already installed the same version of Fedora on an other laptop and it was there.
  • Moreover, lots of Linux users like it not only for the huge amount of creativity and liberty it allows, but also for the well-thought ways to easily secure privacy. Always having to worry about the mic is not part of this philosophy.

So I think it’s more likely an issue linked to the installation itself. I’m missing something.

I agree with you: I’d love to hear from the pipewire/wireplumber developers. I start to realise it’s a very specific request. Maybe only a programmer/contributor to the Fedora OS would be able to resolve it.
Any idea on how to find one?