Archer T3U Plus driver

Hello everyone, I am a new user of this forum and of Fedora in general. I admit that it is really a wonderful operating system and I am really happy with it. However I recently bought a USB Wi-Fi Adapter from TP-LINK. His name is “Archer T3U Plus”. As usual the drivers provided are only for Windows.
Therefore I started to check the internet for some Linux drivers and managed to install one. Everything works fine except when I have to enter the Wi-Fi password: it always tells me it’s wrong even though I’m sure it’s correct.
Unfortunately I don’t know if I installed an obsolete driver or if I made some mistakes. I would like to know if someone knows how to make a device like mine work under Fedora.
Thanks in advance to everyone,

If you know how to compile you can try this:

Archer T3U Plus driver (Linux, Rasbian) - Home Network Community

Hi, thanks for your reply. Unfortunately i don’t know how to compile It. Should i follow the dkms guide on the readme? Sorry but i never did something like this.

Does the password contain a special character? If yes, try to create a simpler password without special characters … so , just numbers and letters. Might be that this solves your problem with the installed driver.

If this with the password not works you can give a try to compile the other driver.
Keep in mind that you need to install dkms first. Might be that you will need other packages installed before you can compile. Just read the error messages carefully and might be good to post them here if you need more help.

Everything has a first time :wink:

Not using Fedora on my desktop, but i do have a usb T3U wifi adapter and i use this driver - GitHub - RinCat/RTL88x2BU-Linux-Driver: Realtek RTL88x2BU WiFi USB Driver for Linux

1 Like

Hello and thank you all. Today I will try to install the driver that ilikelinux recommended. If that doesn’t work I will try the other one suggested. If it’s useful i can say to you that my password doesn’t have any special character. Only letters and numbers.

This worked for me on Fedora 34

I ran this with sudo:

git clone "" /usr/src/rtl88x2bu-git
sed -i 's/PACKAGE_VERSION="@PKGVER@"/PACKAGE_VERSION="git"/g' /usr/src/rtl88x2bu-git/dkms.conf
dkms add -m rtl88x2bu -v git
dkms autoinstall

Since I didn’t have the DKMS kernel headers, I had to install them

sudo dnf install kernel-devel kernel-headers


1 Like