Unable to use Wifi Dongle (T2U Archer)

I tried following TP-LINK AC 600 (Archer T2U Plus) USB-wifi adapter (dongle) - #5 by lcts for a solutions but after getting the rtl8812au folder on my pc through a usb I didn’t find a shell file there to run and when I tried running the make file I got this error:

make ARCH-x86_64 CROSS COMPILE -C/11b/modules/6.0.7-381.fc27.x86_64/build /home/simulatorwinner/Downloads/rtla012au- nodules
make[1]: /Lib/modules/6.0.7-301.fc37.x86_64/build: No such file or directory. Stop.
make: [Makefile:1730: modules) Error 2

& I get error 127 when I try to make dkms install after it runs “dkms add -m 8812au -v”

Also I’m unable to run any dnf cmds as I just installed fedora and now my pc is basically useless without wifi :expressionless: also I’m on mobile rn so rip my battery and time.

Make sure to disable Secure Boot in BIOS/EFI and then build the modules with DKMS:

sudo dnf install git dkms kernel-devel openssl
sudo git clone https://github.com/aircrack-ng/rtl8812au.git \
sudo sed -i -e "/^DEST_MODULE_LOCATION/s|/updates|/extra|" \
sudo dkms add rtl8812au/git
sudo systemctl restart dkms.service
sudo tee /etc/modules-load.d/rtl8812au.conf << EOF > /dev/null
sudo systemctl restart systemd-modules-load.service

You can use USB tethering or Ethernet to gain Internet access.
It is best to fully upgrade and boot the latest kernel before trying to build any drivers.


Welcome to the Fedoraproject @simwin

This looks bad if you just depend on Wifi. Do you not have access to a Router with Rj45 port?
Does your computer have Rj45 port? (Network cable connection)

Alright that worked ty