Application windows go crazy, screenreader does not


Since about two months I’m using Fedora 33 and loving it. Being a software developer with impaired vision, I welcome the up-to-dateness of this distro compared to Debian (which I used before). Now I’ve stumbled upon something I cannot properly put into words - but I’ll try.

On a regular basis my application windows (mostly Firefox, Visual Studio Code, Thunderbird) start to go visually crazy. Characters and parts of other windows spontaneously overlap into the current window. Sometimes the blinking pattern of the VSCode cursor makes an area of 4x8 centimeters blink, too. Sometimes, a big “Fedora” pops into view at the bottom right of the screen, out of nowhere.

All this happens very quickly and seems related to keyboard and mouse actions. For example: when I open an extra tab in Firefox, I see the weird stuff beginning. I then see characters and parts of characters I never saw before - all over the screen.

Now comes the funny part: being visually impaired, I have the Orca screen reader active. It keeps on working completely normal. Even if the screen visually “hangs”, I can navigate with the keyboard and hear what I’m doing. When I restart the gnome-shell (Alt + F2, r, ENTER), the screen goes blank and I can only use my screen reader to logoff or restart the machine.

I have no idea what part of my system is responsible for the things I’m seeing. The problem started a few (kernel-?)updates ago. Now running

Having to logoff-login or restart every time this happens is not normal.
Can someone help me figure this out?



Welcome to ask.fedora @fwiep .

To narrow down your problem would be good if you deactivate all your Gnome-Shell extension to see if your problem still exists. If not, turning on gradually the extension again to find the one who causes this behavior.

Beside this we would like to know more about your infrastructure (Hardware).
inxi -Gxx in terminal shows some more info’s.


Thanks for your quick response. I followed your suggestions and have news.

I disabled all gnome extensions and logged off, then logged in.
Directly after login and starting Firefox, the screen went crazy. At this moment, for example, it visually switches between Firefox (where I’m writing this message) and the terminal window. No other applications are active.

It seems to be triggered by keyboard activity (every time I hit a key, the screen switches back and forth between the two applications.

This is the hardware info from inxi:

Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics vendor: Micro-Star MSI driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:0412 
           Display: x11 server: Fedora Project 1.20.10 compositor: gnome-shell driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 20.3.4 compat-v: 3.0 direct render: Yes 

Just a note: even when all applications are closed, and having a blank desktop wallpaper. When I right click the desktop and choose “Change background” that (settings-) window flickers very fast. So, this seems not to be Firefox-related.

Thanks again,

1 Like

Please give us the info’s of inxi -Fzx to see more about your hardware.

This is the hardware info:

System:    Kernel: 5.10.14-200.fc33.x86_64 x86_64 bits: 64 compiler: gcc v: 2.35-18.fc33) Desktop: GNOME 3.38.3 
           Distro: Fedora release 33 (Thirty Three) 
Machine:   Type: Desktop Mobo: MSI model: B85M-P33 (MS-7817) v: 1.0 serial: <filter> UEFI: American Megatrends v: 4.9 
           date: 03/30/2015 
CPU:       Info: Quad Core model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell rev: 3 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25598 
           Speed: 2087 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 2552 2: 2239 3: 2331 4: 2709 
Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics vendor: Micro-Star MSI driver: i915 
           v: kernel bus ID: 00:02.0 
           Display: x11 server: Fedora Project 1.20.10 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.10.14-200.fc33.x86_64 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: e000 bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
           IF-ID-2: virbr0-nic state: down mac: <filter> 
Drives:    Local Storage: total: 3.89 TiB used: 1.75 TiB (45.0%) 
           ID-1: /dev/sda vendor: Crucial model: CT275MX300SSD1 size: 256.17 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST4000DM004-2CV104 size: 3.64 TiB 
Partition: ID-1: / size: 154.83 GiB used: 44.71 GiB (28.9%) fs: ext4 dev: /dev/sda2 
Swap:      ID-1: swap-1 type: partition size: 20.00 GiB used: 0 KiB (0.0%) dev: /dev/sdb2 
           ID-2: swap-2 type: zram size: 4.00 GiB used: 4.2 MiB (0.1%) dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 278 Uptime: 11h 23m Memory: 15.31 GiB used: 2.42 GiB (15.8%) Init: systemd runlevel: 5 Compilers: 
           gcc: 10.2.1 Packages: 2869 Shell: Bash v: 5.0.17 inxi: 3.1.08


1 Like

I hoped to see more about your keyboard … Have you tried to change the USB port? If you have an other keyboard check if you have same issue. If it is an wireless keyboard check battery status and if you have a other device who could interfere with it.

Btw, i saw that your bios is quite old:

American Megatrends v: 4.9 date: 03/30/2015

Have you tried to get some update ?

Thanks for the suggestions, I tried the following:

  • switched my old (PS/2-)keyboard for another one (also PS/2), no change
  • switched the new (PS/2)-keyboard for an USB one, no change
  • checked the MSI website for an updated BIOS, there is none

Then it occurred to me, I have a braille display, too, which also has some keys for entering characters and quick-nav commands. I don’t know most of these commands, but I know they exist.

I thus disconnected the (USB) braille display and restarted my system. The problem was gone.
I plugged the display in and restarted. The problem is still gone. And keeps being gone, while I start multiple applications in parallel.

Thank you for your help in at least zooming in on this problem. If and when it occurs again, I will take it up on the BrlTTY mailing list.
Update: the problem has occurred again, see below.

Thanks again and sorry for the noise!


I’m sorry to have jumped the gun - the problem still persists and seems NOT to be braille related.

I’ve got my braille display disconnected, the BrlTTY service stopped and disabled, and the xbrlapi command not running.

I also disabled the Orca screen reader. The problem still persists.

This is how I reproduce the problem:

  • start the PC
  • log in to GDM
  • start a terminal (Super + 7, in my case)
  • as soon as the terminal window appears, Gnome-shell’s topbar blinks in the rythm of the bash cursor in the terminal window. At the same time, my last shell command blinks in and out of view in the terminal.

Update: I have tried to record a screencast of the phenomenon with Ctrl+Shift+Alt+R. I had the gnome-system-monitor on the Resources tab, wildly flipping and flickering. Playing back this video on another device, all is well and the graphs of the system monitor do not flip or flicker.

Am I going crazy, or is it just my desktop environment?

Thanks again for your thoughts,

Maybe it’s the cabling to your monitor that is loose?

This we try to find out. Did you realize the effect just lately after a kernel update? If yes try to start a older kernel pressing F10 while booting and choose a older one.

This problem sounds awfully familiar

What do you propose ?

Thank you all for helping trying to sort this out.

Maybe it’s the cabling to your monitor that is loose?

My wife had about the same suggestion: is the screen itself defective?

So, I switched monitors and their DVI-cables. It took a few minutes with the ‘new’ screen, but the flickering is back again. As I’m writing this message, the (part of the) Firefox window (that gets updated while typing?) goes flaky.

Next, I’ll try to reboot and choose another (older) kernel. Running now. I’ll have 5.10.13 and 5.10.12 left to try. I’ll post back here when I do.


With both older kernels, the same thing happens.
When I boot the system, log in and open a terminal window, the top bar and the terminal start to flicker erratically.

Note 1: I use GNOME on, not Wayland (because of the use of the Orca screen reader).
Note 2: when I choose “GNOME classic” instead of “GNOME” in GDM, the problem seems to be gone. But I would really like to keep on using GNOME-shell.
Note 3: Just now, I pulled in a kernel update to 5.10.15-200 and rebooted. The problem is still there.

What else can I try to help diagnose this?


Hello again, I have good news:

Finding the instructions to downgrade Fedora’s kernel right here on AskFedora, I just now installed 5.10.11-200.fc33 and rebooted. The problem seems to be gone!

Actions with which I could surely get the application (and Gnome-shell) windows to go flickery, now do NOT. Finally, we’re on to something!

Now what?


1 Like

Once you have the problem isolated to two kernel versions, you can do a kernel bisection, but you need time and disk space, and it helps to have a spare system.
Bisecting a bug — The Linux Kernel documentation (Finding patch that caused a bug)
1830150 – [BISECTED] Fedora 31 with kernel 5.6 does not wake up from suspend (Notes)

1 Like

Thanks for the suggestion to bisect the kernel. I am trying to, right now.

While doing this (and maxing out my quad-core CPU for quite some time), I see the flickering in Firefox and other application windows appear. Not as much as in later kernel versions, but it’s definitely here, too.

Update 1: booting back into the most recent kernel (5.10.15-200), the problem is gone. I’ll reboot once more into this kernel and check, to be sure.

Update 2: After the reboot of 5.10.15-200, the problem is still gone. I cannot reproduce as I described earlier. I’ll post back when it pops up again. (I both want the problem to stay away and to come back at the same time - very confusing…)


1 Like

I hope that you can track down the problem. It is hard when you can’t reproduce it.
Before doing a kernel bisection, I made a backup to an external USB drive with rsync and I tested that my last Fedora live CD still booted, although I was lucky and never needed either one.
make binrpm-pkg made it easier because I could use dnf to install and remove test kernels.
It can also help to set installonly_limit=0 in /etc/dnf/dnf.conf to prevent dnf from purging old kernels.
If the problem is gone in the more recent kernel, it probably isn’t worth doing a bisection.


I have the same problem since 5.10.x. First I think it was only present en Firefox and youtube, but it was the same in Chrome, and them in most of applications, in wayland and x11. Sometimes graphic system is blocked and I have to maintain the computer running until actions are finished (video codification) and meantime I work (very slowly) in another desktop (Ctrl+Alt+F3). I have a collegue with the same problem. Mine is Fedora33, GNOME 3.38.3, Intel Core i7-3770, HD Graphics 4000, RAM 24GB and the other computer is completely AMD, with the same problems
Any idea?

1 Like

Hi @clopezsandez , welcome to the forum.

A particular kernel version fixed it here. If that doesn’t work for you, please open a new topic.