Announcement: Removal of Fedora from browsers User-Agent string

Hi everyone,

Some of you might notice, that when using Google Chrome 100+ or Chromium 100+ you might have some problems accessing sites such as GitLab (other sites might be affected as well)[0]. This is caused by Cloudfare’s and GitLab’s code that doesn’t like the “Fedora” is the User-Agent (UA) string that we are injecting with the special web extension that is preinstalled on Fedora.

We’ve started injecting Fedora into UA string around 2016 to get Fedora into MediaWiki statistics to get at least a rough idea about how many users we have. During the last 6 years this caused issues from time to time, but I was able to block the extension to alter the UA string on problematic sites. We might come up a similar workaround for the GitLab/Cloudfare case, but we’ve decided that featuring us MediaWiki is way less important than breaking up users access to various web servers. We’ve decided that we will disable the extension altogether with an update to the fedora-chromium-config package[1][2][3] (please test and provide karma! :slight_smile:). Once the update is shipped I will remove the extension from the Google Web Store[4]. We will also stop to modify the UA also in Firefox[5] and in WebKitGTK (used by i.e. Epiphany).

[0] - Chrome v100 with certain user-agent modifications gets stuck at "Checking your browser before accessing gitlab.com" (#358802) · Issues · GitLab.org / GitLab · GitLab
[1] - https://bodhi.fedoraproject.org/updates/FEDORA-2022-68f4b32633 (f34 update)
[2] - https://bodhi.fedoraproject.org/updates/FEDORA-2022-93487ee143 (f35 update)
[3] - https://bodhi.fedoraproject.org/updates/FEDORA-2022-93487ee143 (f36 update)
[4] - Fedora User Agent - Chrome Web Store
[5] - https://bugzilla.redhat.com/show_bug.cgi?id=2081791
[6] - Commit - rpms/webkit2gtk3 - 42e2f04a49563e590d19d24aa23b9832aeee8811 - src.fedoraproject.org

3 Likes