Amdgpu DKMS kernel module in vmlinuz-5.12.5-300.fc34.x86_64 does not build

amdgpu kernel module went broken last Friday.

Fedo34 tries to build kernel module, but cannot finish.
the broken kernel is
linux /vmlinuz-5.12.7-300.fc34.x86_64
linux /vmlinuz-5.12.5-300.fc34.x86_64
worked like a charm.

concerned onboard chip is:
AMD Radeon R600 = R600, RV610, RV630, RV620, RV635, RV670, RS780, RS880

aka: HD2400 - HD4290

Radeon AMD RS780 (DRM 2.50.0 / 5.12.2-1-MANJARO, LLVM 11.1.0 ) (obviously I cannot copy kinfocenter in Fedo any longer so this is Manja)

1 Like

Hey @lff

Pls report this issue on! Thx


1 Like

I take it?


Fedora , component=kernel , assignee being

would be my guess.

1 Like

It should be like this:

1 Like

thanks. However, I already “fixed” it by removing the package

once it dawned on me that “I don’t need a driver (-package)” , i.e. the kernel driver is better suited than the amdgpu package.

1 Like

Hard to to tell these days, what you need and don’t need…

Not sure if I am entirely accurate, but the machine works now!

Even on vmlinuz-5.12.8-300.fc34.x86_64 testing-kernel appearantly after

 sudo dnf --enablerepo=updates-testing install kernel\*

Generally speaking, the binary AMD drivers are not really used anymore. DKMS failures to build after a kernel update typically need to be reported and tracked with whoever provided the kernel driver that dkms is trying to build though. It is never Fedora. Packaging kernel modules outside of mainline is against Fedora policy, and falls to 3rd party repositories to maintain.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.