AMD graphic card HD 4670

I’ve just installed fedora 37 on an old computer with this old AMD HD4560 graphic card installed on it. unfortunately it doesn’t support my graphic card right out of the box. I’m wondering if fedora 37 doesn’t support my graphic card at all or there are some ways to make it happen. I’m a new Linux user so there are a lot of things that I don’t know about it.

ATI/AMD HD4560 (r700 family) should be working out of the box with in-kernel GPU driver (radeon) and OpenGL mesa driver (r600).
Why do you think that your card is not supported?
Run this in terminal sudo inxi -GMSsaz, paste here the output, select it and format by pressing Ctrl+e.

it says:
“command not found.”

I think you’re right in the setting->about , I can see it’s written graphic is AMDRV730, that means it recognize it. but my resolution is not right my monitor has the 1366768 resolution but in the Display menu I see it’s written 1024768(4:3) which is not right.

probably it doesn’t recognize my monitor size properly. how should I force it to give me that resolution?

  Kernel: 6.0.11-300.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37
    parameters: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.0.11-300.fc37.x86_64
    root=UUID=fe414ee0-3a9f-431a-9e54-da2d858758bb ro rootflags=subvol=root
    rhgb quiet
  Console: pty pts/0 wm: gnome-shell DM: GDM v: 43.0 Distro: Fedora release
    37 (Thirty Seven)
  Type: Desktop Mobo: ASUSTeK model: P5P43TD v: Rev X.0x serial: <filter>
    BIOS: American Megatrends v: 0502 date: 10/30/2009
  Device-1: AMD RV730 XT [Radeon HD 4670] vendor: ASUSTeK driver: radeon
    v: kernel alternate: amdgpu arch: TeraScale process: TSMC 55-65nm
    built: 2005-13 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 2
    speed: 5 GT/s ports: active: VGA-1 empty: DVI-I-1,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 1002:9490 class-ID: 0300 temp: 45.0 C
  Display: server: X.Org v: 22.1.5 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: dri: r600 gpu: radeon note: X driver n/a
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 271x203mm (10.67x7.99")
    s-diag: 339mm (13.33")
  Monitor-1: VGA-1 mapped: XWAYLAND0 res: 1024x768 hz: 60 size: N/A modes:
    max: 1024x768 min: 640x480
  API: OpenGL v: 3.3 Mesa 22.2.3 renderer: AMD RV730 (DRM 2.50.0 /
    6.0.11-300.fc37.x86_64 LLVM 15.0.0) compat-v: 3.0 direct render: Yes
  System Temperatures: cpu: 39.0 C mobo: 39.0 C gpu: radeon temp: 45.0 C
  Fan Speeds (RPM): cpu: 3139 case-1: 0
  Power: 12v: 12.41 5v: N/A 3.3v: 3.41 vbat: N/A

You don’t seem to have mentioned trying to change the display resolution.

I don’t use gnome much, so I can’t help navigate you through settings. But display settings should be pretty obvious.

Does it fail to offer the resolution you want? If you can select the right resolution, I assume it will be correctly saved and will be your resolution the next time you log in (with the same physical display(s) active.)

If it offers that choice and you only need to select it once, you shouldn’t really care that it initially failed to detect the display’s preferred resolution (it should be able to detect that, but doing so isn’t critical).

If it doesn’t even offer the correct resolution, that can be a bit harder to deal with.

The file /var/log/Xorg.0.log often has the reasons it chose the resolutions it offers and not others. That tends to be hard to decipher amid lots of irrelevant stuff, but may be worth checking.

There are commands you can easily find online (typically using xrandr) to tell the graphics driver to support a resolution that it doesn’t think it should support.

it doesn’t offer the resolution I used to see on this monitor.
I tried “xrandr” commands to force it give me my desired resolution. but in the end it ggave me this:

xrandr --output XWAYLAND0 --mode 1366x768
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Value in failed request:  0x0
  Serial number of failed request:  22
  Current serial number in output stream:  22

That was telling it to use a resolution it does think it should support.
It takes more to tell it to use one it doesn’t think it should support.

Many online sites explain it (and there are a few ways to do it). Typically they tell you to use cvt to find out the required details:

[john@linux ~]$ cvt 1368 768
# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

Then use that in

xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

But then I haven’t found the details for Wayland. If it weren’t Wayland (or if done before Wayland starts) something like:
xrandr --addmode DP-1 "1368x768_60.00"
replacing the DP-1 with the correct connector name for your display card.

Also, for continued use all that should be in a script for the GUI startup.

it worked :heart_eyes: :heart_eyes: :heart_eyes:
thanks alot

For my curiosity and/or anyone with a similar problem who finds this thread, what worked?

Did you put the --newmode and --addmode commands in some script that executes after X starts but before Wayland starts? If so, what script? For sddm/kde, which I use, I know that would be /etc/sddm/Xsetup. For gnome, I have no idea.

Or did you find a way to make those commands work after Wayland is already running? I never got that to work.

Or some other way?