After upgrading to Fedora 38, I can't build any tauri apps that need nodejs

error: The subcommand '/usr/bin/node-18' wasn't recognized

    cargo-tauri [OPTIONS] <SUBCOMMAND>

For more information try --help
error Command failed with exit code 2.

openSUSE also encountered this problem before, but tauri‘s developers later fixed it.

Please be aware that fedora 38, while branched, still has not even reached the beta stage. You are running a testing version and many things that will work on the released versions may not function in a testing version…

This is not the best place to get support on the branched fedora 38, especially related to building apps.
I do not have access to my bookmarks at present, but someone may be able to give you a pointer to the proper support location for F38.

Thanks for assisting in the testing of the upcoming release.

Report to tauri upstream. When they fixed that previous bug, they expected the node binary to match a certain pattern:

if (binStem.match(/(nodejs|node)([1-9]*)*$/g)) {

This does not match node-18.

1 Like

I’m also having this issue on Fedora 37

I find it very odd that even though i installed nvm and the binary is ‘node’ the tauri.js script picks up the older node-18 binary. modifying line 8 of tauri.js to

const binStem = 'node'

has temporarily resolved my issue.

1 Like

i’ve tried nodejs official repo instead of the fedora.repo

I opened an issue now over at [bug] `npm run tauri dev` and similar commands failing after upgrading to Fedora 38 · Issue #6759 · tauri-apps/tauri · GitHub

1 Like

Should be resolved in version v1.3 of Tauri

See also

1 Like