After resuming, system wakes properly but screen is blank

I’m having trouble (I think) with the graphics driver on my laptop (Intel HD Cherrytrail, Acer sw3-016). When the laptop boots everything is fine, but when it suspends then resumes the screen remains black (although the backlight comes on). The system hasn’t crashed though, because I can still type commands and hear sounds, I just can’t see anything…

This is the bug I want to fix, but there are some other oddities that I think may be related:

I have tried several other distros on this laptop, all with the same issue. Hence I do not think it is gnome related. This happens even if I suspend from a VT.

If I run gnome under X, it starts fine, but when I rotate the screen (it’s a laptop/tablet) the display goes black and never comes back, although the system keeps responding to input (rotation under wayland works fine).

If I attempt to change the resolution, the screen goes black as above.

This makes me think it is a graphics issue. I’ve been trying to find which package to file this bug against, but I’m unsure which to select. Any help you can give me would be greatly appreciated!