4k 60hz over HDMI, sound is messed up

Hello !

I recently installed linux on this PC, which is connected via HDMI to a 4k TV, and I am having weird issues on linux (everything is working just fine on Windows). I have tried many distros, (debian, ubuntu and derivates, arch and manjaro, fedora and opensuse) and on all of them I have the same problem. Either I can’t go over 30hz, or if I add a new resolution with 60hz on Xorg, and it switches to 60hz, then every video and audio is too fast (sounds like chipmunks), local files, youtube, I even tried a live stream, and it would play faster then stop to buffer, play too fast, then buffer again…

I have tried many versions of pretty much everything at this point, tried messing around with pulseaudio, tried many HDMI cables (even though they all work on Windows), I found out that if I set the output to my USB headset, the playback is normal (sound works fine too), if I switch it back to HDMI output it’s back to faster … I just can’t find a solution. Right now I am on fedora 31, on kernel 5.3.1-300, gnome 3.34.0.

I don’t really know what info you guys need to begin with so I’ll add them as needed, the PC is a i7 4770 with a RX Vega 56.

Hope you guys can help me, thank you!

That’s a weird one. It appears to be an issue that’s been around for a bit and is related to some AMD GPUs. I haven’t experienced this 1st hand, but

  1. Make sure you have no unused audio cables (even HDMI) dangling with no connections
  2. This solution seems to work for some:

In the file /etc/pulse/daemon.conf replace

default-sample-rate = 44100 with

default-sample-rate = 48000

Then restart pulseaudio

pulseaudio -k

good luck.

Thanks for the reply!
Unfortunately I do not have extra cables connected and I already have tried changing this setting (and many others)