WireGuard connection doesn't save persistent-keepalive value

, ,

Hi All,

I have a problem with the KDE network manager, where Persistent Keepalive doesn’t get set correctly when using the WireGuard connection profile.

I’ve also posted on the kde bugzilla, but been told to come ask here.

I’ve got a WireGuard profile, when I add a Persistent Keepalive to a peer via the the applet, press apply. The setting doesn’t actually apply, if you reopen the applet then the connection, the field is then blank again. You don’t need to connect with the profile, just try setting it and then close the applet window and then go back in to check it’s applied.

If you set the persistent-keepalive directly in the .connection file and reload network manager. It’ll then show in the NetworkManager Applet, but making any changes to the connection to the peers list will cause the persistent-keepalive to be unset once again using the applet.


  1. Open WireGuard connection profile in nm-applet
  2. Go to the WireGuard Interface tab
  3. Click peers
  4. Add value like 25 to Persistent Keepalive
  5. Click OK to the Peer Properties window
  6. Click Ok to the Connections- System Settings window
  7. Open WireGuard connection profile in nm-applet
  8. Go to the WireGuard Interface tab
  9. Click peers
  10. See value wasn’t applied.

persistent-keepalive isn’t set

persistent-keepalive should be set to defined value

Linux/KDE Plasma: Fedora Linux 36
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6

System is fully up to date, as of writing this bug.

Bug also happens in Fedora Linux 37
KDE Plasma Version: 5.26.2
Will carry on upstream

btw, nm-applet is a specific GUI application. The thing you use in KDE is not usually nm-applet (but plasma-nm?). Also, nm-applet is not a GUI for editing connection profiles, so it’s clear you are not actually using nm-applet. Anyway.

This sounds like a bug in plasma-nm. As the upstream report told you, that they are not keen on fixing this on an “old” version, there isn’t much you can do.

If the GUI you are using appears to have a bug, then use another application as workaround. For example, use nm-connection-editor (by starting it from a terminal). It’s a GTK application, but you can use that in KDE just fine.

That’s for pointing out I said the wrong product.

It also happens on 5.26.2 which is a supported version as per their message.
supported versions are 5.24, and 5.26 or newer.

I just edited the connection file and reload network-manager to get the setting set.

Sounds good. Just to confirm, editing the file in /etc/NetworkManager/system-connections (followed by nmcli connection reload) is a perfectly acceptable workaround :slight_smile:

Correct it’s a handy workaround.