WinSCP alternative for Fedora

Hello, dear community. I need help with packages. I am looking for an alternative WinSCP for Fedora. The main problem is that I am working with old servers with SCP protocols and all set up there. I know that I can do the same operations via terminal in Fedora, but when you work with many systems it takes too much time. I work with more than 100 systems, so it can take a crazy time to connect to all and upload files to each. What can be an alternative WinSCP for Fedora? Thank you

I think you can use Gnome Files for this. Click on Other Locations in the left hand bar. Then you should find label that says Connect to Server on the bottom bar. I believe it understands things like sftp://:/path/. There is a question mark there that you can click to see the various protocols it supports.

Thank you, Steve. I tried it already, and unfortunately, sftp and scp are not the same. It does not work…

Hi Jorjio,

Closest by is FileZilla, but again: this supports SFTP. On regular Linux systems this is enabled on the SSH server. Reading the manual, WinSCP needs a lot of hacking combining ssh and scp to combine the GUI functionalities with only ssh/scp availability.
May be you can do a basic check with “sftp <hostname>” to see whether it’s really disabled on your remote systems. If disabled, I do not know an alternative.

Thank you ,hmmsjan ! I did it, no, works only with SCP. FileZilla does not work =(
I got Fatal: unable to initialise SFTP on server: could not connect, every time.

Yes, then your servers have sftp disabled or not present. I was thinking to have a nice solution, “sshfs”, where you can mount a remote folder via ssh on a local folder, but after disabling sftp on the server, it failed. Hope somebody knows a trick…

May be there is one, but this runs within a terminal, and is for sure not as user-friendly: mc

It is not as user friendly as WinScp or Filezilla, but you have a file listing left and right and you can copy between them, at the moment that SFTP is not active. Problem may be could be the other side’s operating system. There are a lot of commands issued by the remote sshd to prepare and format the directory listing, and they should be present and interpretable.
I would say, give it a try. I have the impression that it even does not use SFTP when available, but I could be wrong.

1 Like

Maybe I’m daft, but doesn’t ssh:// work in that case:

This is from Gnome Files…

1 Like

SSH File Transfer Protocol (sftp) and secure file copy protocol (scp) are not the same thing. If the target host unfortunately supports only scp (it must be a very old deployment, OpenSSH deprecated scp in 2019), you can’t use Gnome Files and FileZilla because they support only sftp.


I tested “mc” on a very old NAS. It works, but the size of all files and directories is 1.3Gbyte. Surprisingly, date and time are correct. I do not see any difference in “ls -l” output on both.
Highly confusing is the keyword “FISH”: it’s both a shell and a virtual file system implemented in “mc”. No sftp. You do not need to go back to the text-mode “mc”. It’s implemented in KDE’s Dolphin, and the remote can be opened by
fish://remotenameorip. Unfortunately, with the old NAS every file is 1.3 GiB in Dolphin too… Just try it on your systems, it might work.

Addition: in my case, the size problem could be worked around by removing perl from the remote. Perl lstat returns zero for filesize there for some reason.

WinSCP and what is called FISH do the same: they open a SSH connection without tty and run a bash shell in it. Bash commands or Perl scripts implement the necessary functions.

So “mc” and KDE’s “dolphin” are WinSCP alternatives in Linux,
requiring SSH and on the other side a bash-like shell and optionally perl, no SFTP.

KDE implements it via library /usr/lib64/kde4/, and the “fish://” url can be used in file open dialogs too.

Why don’t you try using ansible? If you are managing 100+ servers, the effort put learning ansible is absolute a good idea. You can copy files, you can check if the file is already on the target, you can copy only if the source is newer than the target Very flexible and nice.

Thank you, everybody. After a couple of days, team made the decision to activate sftp on the servers. Thank you for your help
P/S it works with MC