Weird Icon Sizes in Nautilus List View

Problem

In Nautilus Grid View, icons for files may have different sizes. This seems to appear randomly for some files and some folders.
This only appeared since I did a fresh install of Fedora Workstation 40 (not an update). Root / was reformatted, but not my /home folder.

Cause

New Fedora Workstation 40 install with Gnome and Wayland.

Not yet known.

Related Issues

Not known.

Workarounds

None yet.

Added f40

From Proposed Common Issues to Ask Fedora

Well,

this does not seem to me as a default settings, as I am only using defaults on my machines, and my Nautilus looks different and also does not have any problems with the icon size. See the screenshot at the end of the post.

I tend to believe that in your configuration files in your home directory, there might be remains of previous settings that might no longer be valid with the new Nautilus, or since your icons look different, they might have dropped support for the motive of your icons and some type (binary) might be missing.

I suggest you delete this configuration, or you switch back the defaults, check that it works and then start from scratch with customizing your settings.

That looks to me like “List View” as Grid View is all thumbnails. Also, you mentioned :

Is it possible you have remnants of an Icon pack or themes from the previous install, since you did not reformat your /home

I use default icons and themes. I never installed any icons nor theme packages.

Most icons are normal, just a few are very large. It seems totally random that a few files get a large icon and others don’t. And it can change after a reboot.

I went through .config and .local and deleted several files. Nothing changed after reboot.

Any place where I could look?

Added nautilus

I used Nautilus for years and it definitely defaults to icon view (including F40 GNOME 46) :stuck_out_tongue:


On F40 and openSUSE TW both GNOME 46 I haven’t seen this Wayland nor Xorg on Intel UHD 630, but I never changed the icon view to list (only kept it at default icon view).

Several Fedora releases ago when I had an AMD RX 6600 XT GPU, on KDE Plasma 5 Xorg if I forced the AMDGPU DDX driver, some parts of Plasma 5 would scale (I did global 200% scaling) and others wouldn’t. Everything scaled fine if I used the default modesetting DDX driver though. I don’t know what exactly was going on there but maybe something related is happening here?

I am not talking about default views, I am talking about default settings of the application. If you take a closer look, you will see that @macxpat1 color scheme is dark, but by default, there is no dark scheme used on Nautilus.

When we test applications, it is important to test the most default settings first, because this is how things will be after installations. If customization create problems, that is another story. Therefore I have learnt not to customize anything on my system and as you can see, the default color scheme of Nautilus is indeed white.

Also, when you check the folder icons, you will see that they also have another color, a little different shape and also tiny little arrows on the left hand side. You will not find anything like that in my screenshot of the default application.

The question is Why does your Nautilus look so different, if you claim that it is the default?

Maybe:

  • The application is not Nautilus?
  • The DE is not pure Gnome?
  • There are customized settings on the system?

As I have already said, my hit would be that @macxpat1 installed his system some time ago and did customizations to it, because he liked dark scheme better than the default, he might have changed the style of the icons, because he liked them better and now, when he has reinstalled their system, those old settings became unsupported and the components have disappeared from the installation.

If he would not have reinstalled, but rather upgraded, it is very probable that the system would have kept that support and you would not notice anything. However, the newly installed system did not bring that support with itself and the customizations, located somewhere in his user config files, arrive into problems like missing icons. Have you noticed that the big icons are all binary files, while text files are shown correctly?

@macxpat1, you can try to download the newest Workstation Live and just boot it on your computer, run Nautilues and see if the problem persists. I believe that everything will be ok, because everything seems to be ok on my freshly installed system, as you can see from the screenshot. To find where the problem lies could take some time and energy, of course, because the customizations might have been done via Gnome Tweaks and not the regular settings, so the configs might basically lie anywhere in your home directory. Start in the .config or .local.

Also, you can create a new user and log into that new user and see how Nautilus will look like. If it will be different than yours, you will know for sure it is customization.

1 Like

Let’s clarify again the situation here:

  • Plain vanilla Fedora Workstation 40 with Gnome on Wayland.
  • I did not install any icons or theme packages, ever.
  • The file manager is Gnome Files, also known as Nautilus.
  • I’m using the Dark style proposed by Gnome in Settings > Appearance (see fig).
  • Changing to Default style, i.e. white, doesn’t solve the weird icon size issue (see fig).
  • As I said before, I already went through .local and .config and didn’t find anything special.

So finally, I checked Tweaks in Appearance > Styles.
The icon style indicates Gnome.
Well, if that ain’t a default style for the Gnome desktop environment, what would be?
Meh, I pull down the menu and found that Adwaita was the default stye.
Choosing Adwaita resolved the issue: no more weird icon sizes. :grinning:

I checked the other menu choices: the weird icon sizes only appear with the Gnome and Hicolor styles.

Indeed, I remember now choosing Gnome as icon style a few years back, because I didn’t like the Adwaita icon style. I never went back to Tweaks anymore. Thank you for the stimulating exchange! :laughing:

So, we have a bug here.

Case closed for me.



I cannot correct the title of the topic, but the issue is in List View, not Grid View.

This should be files as a bug against gnome settings and/or nautilus so it can be fixed. I can easily see where the confusion appears.