Use a proxy during installation

I am trying to configure a proxy to be used during installation, but apparently it is ignored.

This is what I’ve tried

  • a squid instance in local network is configured to cache various types of files, among them those with rpm extension
  • during setup, I choose “closest mirror”, then click on “proxy”, set the IP/port of my internal proxy, then tick “Enable proxy”

When installation starts, nothing is cached, and it looks like the setting is ignored.

If I later configure the proxy adding the entry in /etc/dnf/dnf.conf, I do see downloaded files cached in the folder configured in squid.

So wondering what I am doing wrong during installation…

Any suggestion?