Upgrade fedora 31 to 32

I try to day to upgrade from fedora 31 to 32. But I got this error:
Errors during downloading metadata for repository ‘skype-stable’:

  • Curl error (28): Timeout was reached for https://repo.skype.com/rpm/stable/repodata/repomd.xml [Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds]
    Error: Failed to download metadata for repo ‘skype-stable’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Ignoring repositories: Dropbox, skype-stable
    Problem 1: package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  • package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  • eclipse-epp-logging-2.0.7-8.fc31.noarch does not belong to a distupgrade repository
  • problem with installed package eclipse-usage-4.11.0-1.fc31.noarch
  • package eclipse-epp-logging-2.0.8-1.module_f32+6163+c0e6dcb2.noarch is filtered out by modular filtering
    Problem 2: package python2-twisted-19.2.1-6.fc31.x86_64 requires python2.7dist(automat) >= 0.3, but none of the providers can be installed
  • python2-Automat-0.7.0-4.fc31.noarch does not belong to a distupgrade repository
  • problem with installed package python2-twisted-19.2.1-6.fc31.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages)

Can someone help me? How can I remove Skype and I solve the issue?

Assuming these problems appear when you run dnf system-upgrade --releasever=32, you can try with the following flags:

dnf system-upgrade download --refresh –skip-broken --allowerasing --best --releasever=32

I don’t think skype is blocking the update, much like dropbox, it will be ignored.

You can also remove offending packages manually, before running the upgrade:
dnf remove eclipse-usage eclipse-epp-logging python2-twisted

If for whatever reason you want to remove skype, the package is called skypeforlinux:
dnf remove skypeforlinux

1 Like

Hello !

I don’t want to upgrade to Fedora 32 but I have the same issue with Skype when I run sudo dnf update
Even after dnf remove skypeforlinux

Do you know how to fix this ?


1 Like

@benjaminbourgeois nice to meet you. Today update for skype was very slow here also. Maybe just try tomorrow again?

You can temporarily disable any repository during a dnf transaction with --disablerepo=<name_of_repo>, so the command I gave above would become:
dnf system-upgrade download --disablerepo=skype-stable --refresh –skip-broken --allowerasing --best --releasever=32

If you don’t want to type this every time, but you want to keep the repository in place, you can disable it with:
dnf config-manager --set-disabled skype-stable

Essentially this command sets the “enabled” variable in the repo file to 0, so another way to do that would be by directly editing the file /etc/yum.repos.d/skype-stable.repo.

# cat /etc/yum.repos.d/skype-stable.repo
name=skype (stable)

Conversely, with the repo disabled, you can enable it per dnf transaction with --enablerepo=<name_of_repo>. When they fix the problem, you can enable the repository again by setting enabled=1 directly in the file or with
dnf config-manager --set-enabled skype-stable

1 Like

But someone know how to solve the issue with eclipse?

Didn’t this work for you?