Unknown display in Fedora 31

I have a problem recognising my HP laptop display on fedora. I have an Intel UHD Graphics 630 and a GeForce GTX 1050 graphics card, but no drivers on both.
Because of that I can’t change brightness, resolution of the screen or connect a second display on HDMI port.
Please help me!!!

This is the output to inxi -G:

Device-1: Intel UHD Graphics 630 driver: N/A
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A
Display: x11 server: Fedora Project X.org 1.20.6 driver: vesa
unloaded: fbdev,modesetting resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 9.0 256 bits) v: 3.3 Mesa 19.2.8

Welcome to the Fedora Community @pietromello
sudo lsmod | grep nouveau
sudo lsmod | grep nvidia

Looks like Optimus technology.
Which graphics card drives the HDMI?
At least one card is giving you graphics … as per the screenshot. Looks like its the Intel Card but it is not properly recognized. I assume you logged in with with Xorg and not Wayland. What happens when you attempt to log in with the defaults (wayland)?

This page may be describing your issue:
try booting with i915.alpha_support=1 as one of your kernel parameters and see what happens

More reading:



Thank you for your answer,
This is the output of the two commands:

sudo lsmod | grep nouveau
nouveau 2273280 0
mxm_wmi 16384 1 nouveau
ttm 122880 1 nouveau
i2c_algo_bit 16384 2 i915,nouveau
drm_kms_helper 233472 2 i915,nouveau
drm 585728 4 drm_kms_helper,i915,ttm,nouveau
wmi 36864 5 hp_wmi,intel_wmi_thunderbolt,wmi_bmof,mxm_wmi,nouveau
video 53248 2 i915,nouveau

sudo lsmod | grep nvidia

I added the i915.alpha_support=1 parameter to kernel adding the line to /etc/default/grub and then running grub2-mkconfig -o /boot/grub2/grub.cfg.

I wasn’t able to log in with wayland, clicking the icon in the log in page I had two chices: GNOME and GNOME classic, both running with X11.
I don’t know if it may help, but I did the installation with the basic grafics mode because the normal one was not succeding.

Anyway by now the display is still unknown sadly.

Ah! … then we need to see your current kernel parameters. Since the installation was done with basic graphics, the settings in GRUB will remain basic until you rebuild it. Your outputs show that the drivers are loaded alright.

Ok, the parameters in my grub files are these:

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap nomodeset rhgb quiet i915.alpha_support=1"

remove that, rebuild grub, update your system, reboot, and share your experience

I removed nomodeset, reran
grub2-mkconfig -o /boot/grub2/grub.cfg
and rebooted the system.

It rebooted but after typing the password in the login page a dark blue page shows up and nothing works…