Unable to install Nvidia Drivers - no nvida kernel module

I installed Fedora 2 days ago. I looked a little before and saw you want to install using rpmfusion. When I installed Fedora, I installed the Nvidia 510 drivers through gnome software as it said its rpmfusion. It installed fine, but it was acting kinda wonky where the Nvidia X server settings was there, but it blank. It was only and there were 2 menus on the side which is way less than normal and when selecting either menu it was just white. I also wanted to install cudnn and a few other things that didn’t work, but it could have pretty easily just been me doing it wrong.

I decided to reinstall, so I uninstalled through gnome software then blacklisted nouveau and rebooted. I reinstalled through gnome software again and rebooted. It said that the NVIDIA kernel module was not installed, and it was reverting to nouveau while rebooting. I have a GUI still. If I try to install the driver’s with the instructions from the rpmfusion site instead, I get a bunch of errors like this:
Problem 2: package akmod-nvidia-3:510.47.03-2.fc35.x86_64 requires nvidia-kmod-common >= 3:510.47.03, but none of the providers can be installed
I also want/need cuda and get the same error for cuda.

1 Like

Two questions.

  1. have you done a full system update sudo dnf update since the initial install?
    The update should be done before installing the nvidia drivers.
  2. What command (exactly please) did you use to do the install of the nvidia drivers?
    I use sudo dnf install akmod-nvidia*510* which pulls in all the appropriate packages needed.

Installing cuda is then one more simple command. sudo dnf install xorg-x11-drv-nvidia-cuda

1 Like

Yes, I have tried dnf update install a few times. Both sudo dnf install akmod-nvidia*510* and sudo dnf install xorg-x11-drv-nvidia-cuda do the same thing. I have installed other things after I have this issue, it seems like it’s just related to Nvidia for some reason. I realized I only put the first line. This is everything it says.

 Problem: package xorg-x11-drv-nvidia-cuda-3:510.47.03-1.fc35.x86_64 requires nvidia-persistenced(x86-64) = 3:510.47.03, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package nvidia-persistenced-3:510.47.03-1.fc35.x86_64 is filtered out by modular filtering

Can we have the output of dnf repolist please?

Yep. Apparently it seems that the driver issue was partially due to 510. Reverting to 470 installed fine. Cuda still has the same issues installing though.

repo id                                                                   repo name
copr:copr.fedorainfracloud.org:t0xic0der:nvidia-auto-installer-for-fedora Copr repo for nvidia-auto-installer-for-fedora owned by t0xic0der
cuda-fedora35-x86_64                                                      cuda-fedora35-x86_64
cudnn-local-rhel8-                                                cudnn-local-rhel8-
fedora                                                                    Fedora 35 - x86_64
fedora-cisco-openh264                                                     Fedora 35 openh264 (From Cisco) - x86_64
fedora-modular                                                            Fedora Modular 35 - x86_64
google-chrome                                                             google-chrome
nvidia-machine-learning                                                   nvidia-machine-learning
phracek-PyCharm                                                           Copr repo for PyCharm owned by phracek
rpmfusion-nonfree                                                         RPM Fusion for Fedora 35 - Nonfree
rpmfusion-nonfree-nvidia-driver                                           RPM Fusion for Fedora 35 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                                                   RPM Fusion for Fedora 35 - Nonfree - Steam
rpmfusion-nonfree-updates                                                 RPM Fusion for Fedora 35 - Nonfree - Updates
updates                                                                   Fedora 35 - x86_64 - Updates
updates-modular                                                           Fedora Modular 35 - x86_64 - Updates

Please give us the exact and complete message when the command sudo dnf install xorg-x11-drv-nvidia-cuda fails.

Which version of the 470 driver groups did you install?
With the rpmfusion-nonfree repo enabled you could have installed the 470.74 version. With the rpmfusion-nonfree-nvidia-driver repo you could have installed the 470xx version.

The 470xx version is a metapackage that is intended to not automatically update to the 510 version since the 510 version has dropped support for some older cards and not updating to the newer driver is necessary for those with the older GPU cards.

Try it this way if you installed the 470.74 version
sudo dnf upgrade akmod-nvidia --disablerepo=cuda-fedora35-x86_64 --disablerepo=cudnn-local-rhel8- and see if that works.
If instead you installed the 470xx version then try sudo dnf swap akmod-nvidia-470xx akmod-nvidia-510.* --allowerasing --disablerepo=cuda-fedora35-x86_64 --disablerepo=cudnn-local-rhel8- and see if that works.

If neither of those work then we need to more directly address the error about package nvidia-persistenced-3:510.47.03-1.fc35.x86_64 is filtered out by modular filtering

Once the nvidia driver issue is sorted then we can address the problem with installing xorg-x11-drv-nvidia-cuda.